Bug 449218 - transmission redownloads torrent if files have been moved after successful download
transmission redownloads torrent if files have been moved after successful do...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: transmission (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-31 09:50 EDT by Martin Jürgens
Modified: 2008-09-28 10:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-28 10:35:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Jürgens 2008-05-31 09:50:27 EDT
Description of problem:
transmission redownloads torrent if files have been moved after successful download

Version-Release number of selected component (if applicable):
latest in fedora

How reproducible:
always

Steps to Reproduce:
1. Download some thing with Transmission
2. When the download has finished, close transmission
3. Move the downloaded files to some other location
4. Open Transmission again
  
Actual results:
Transmission redownloads the torrent..

Expected results:
Transmission should remove it from the list / spawn an error message.

Additional info:
Comment 1 Denis Leroy 2008-05-31 12:43:51 EDT
It seems to me that this would be the expected behavior. You have to remove the
torrent from transmission first, otherwise transmission is expected to seed it.
If it's not there, it'll redownload.

I'll file a ticket upstream nonetheless, perhaps the disappearance of the data
after a successful download should be interpreted as an automatic "remove"...
Comment 2 Martin Jürgens 2008-05-31 12:58:19 EDT
Thanks for doing so.. Yes, it seems to be logical to me if it redownloads it if
the files are not there (anymore), but when it has finished downloading it it is
a different situation, as you already mentioned.

I just think that it is a waste of resources because it happened to me that I
downloaded some torrents twice, just because I moved the folder and didn't have
a look at what else Transmission downloads / seeds.
Comment 3 David Nalley 2008-09-26 23:05:02 EDT
I'd tend to agree with Denis and say that this appears to not be a bug. The controlling factor with any bittorrent client's activity is the torrent file, not the downloaded files. 
However there is a bug for this upstream 
http://trac.transmissionbt.com/ticket/476
http://forum.transmissionbt.com/viewtopic.php?p=13871
Comment 4 Denis Leroy 2008-09-28 10:35:50 EDT
Closing, as this is an RFE rather than a Fedora-specific problem. We'll let upstream decide on how to proceed here.

Note You need to log in before you can comment on or make changes to this bug.