Bug 449232 - Kate cannot indent with tabs anymore
Kate cannot indent with tabs anymore
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdesdk (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-31 15:02 EDT by CS Wagner
Modified: 2008-06-02 12:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-31 16:19:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description CS Wagner 2008-05-31 15:02:41 EDT
Description of problem:
New "feature" in Fedora 9/KDE4 is that Kate cannot increase indentation levels
using tabs.  It can only use spaces.  Previous versions of Kate used the
indentation found on the line.  If it was indented with tabs, it added another
tab.  If it was indented with spaces, it added more spaces.

Version-Release number of selected component (if applicable):
Kate 3.0.4/KDE 4.0.4

How reproducible:
Create a file (program/script).  Indent with tabs.  Highlight some code and
increase indentation level.  It will add spaces, not tabs, to increase the
indentation level.

Steps to Reproduce:
1. Create code with tabs
2. Highlight part of the code
3. Increase indentation level
  
Actual results:
Spaces are added to increase indentation level.

Expected results:
An extra tab should be added to increase indentation level.

Additional info:
The expected response to this is, "Just use spaces, not tabs."  However, I have
many years of code that uses tabs for indentation.  I do not want to go through
600 gigs of code and convert all tabs to spaces just to make a bug in Kate feel
warm and fuzzy about itself.
Comment 1 Rex Dieter 2008-05-31 16:06:28 EDT
This is (mostly likely) an upstream issue, not a fedora one.  You'd be better
served reporting this to bugs.kde.org.  When/if you, please let us know, so we
can continue to track the issue there.
Comment 2 CS Wagner 2008-05-31 16:18:37 EDT
On bugs.kde.org, I found that the feature has not been removed.  The redesign of
the configuration is a mess.  If you set the tab level and indentation level to
the same number of characters, it will indent with tabs.  Otherwise, it will
indent with spaces.  There are complaints of inability to indent with spaces
(because both are the same) as well as inability to indent with tabs (because
they are set different).  It is obvious that the configuration panel needs a
redesign to make it clear what the user is setting.
Comment 3 Kevin Kofler 2008-06-02 12:51:09 EDT
FYI, there are several bugs filed upstream about this and related issues, some 
of them by me.

Note You need to log in before you can comment on or make changes to this bug.