Bug 449246 - Metacity ignores focus_new_windows gconf key on login
Metacity ignores focus_new_windows gconf key on login
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-31 17:30 EDT by Anze Zagar
Modified: 2014-06-18 05:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-31 17:58:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anze Zagar 2008-05-31 17:30:22 EDT
Description of problem:
Having focus_new_windows set to its default value (i.e. smart), new windows
never get focus which is supposed to be more a 'strict' behaviour.

Version-Release number of selected component (if applicable):
2.22.0-3.fc9.i386

How reproducible:

Steps to Reproduce:
1. Start Fedora 9 in Gnome having Metacity its default WM
2. Open gnome-terminal
3. Open another gnome-terminal
  
Actual results:
The first gnome-terminal will keep focus and remain displayed above the newly
opened gnome-terminal

Expected results:
The newly opened gnome-terminal should take focus and raise above the old one

Additional info:
As a workaround, I can restart metacity with 'metacity --replace' and behaviour
is changed back to normal/expected.
Comment 1 Anze Zagar 2008-05-31 17:58:47 EDT
Sorry. Turns out that Devil's pie was causing this. Adding '(focus)' to its
settings file fixed this problem. Interesting that I haven't had such experience
with any of the previous releases of Fedora although I have always been using
Devil's pie.

Note You need to log in before you can comment on or make changes to this bug.