Bug 449279 - totem-video-thumbnailer fails to work with flash video files
totem-video-thumbnailer fails to work with flash video files
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-01 12:37 EDT by William Lovaton
Modified: 2008-09-28 14:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-28 14:39:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Lovaton 2008-06-01 12:37:05 EDT
Description of problem:
I have some flash videos (.flv) on my hard drive and nautilus doesn't show the
thumbnail of the video.  It just show the default icon, although totem can play
the files just fine, the problem is in the thumbnail generation only.

It used to work fine with Fedora 8 but it doesn't with Fedora 9.

If I execute totem-video-thumbnailer in the command line it works fine:
totem-video-thumbnailer video.flv video.png

But I get the following warning:
** (totem-video-thumbnailer:4592): WARNING **: Unknown codec ID 86022, please
add here

Maybe because of this output nautilus thinks there was an error and fails to
show the preview.

What can the problem be? it seems it works but not through nautilus.

The system is up to date.


Version-Release number of selected component (if applicable):
totem-2.23.2-2.fc9.i386
nautilus-2.22.2-7.fc9.i386
gstreamer-0.10.19-1.fc9.i386

totem-gstreamer-2.23.2-2.fc9.i386
gstreamer-plugins-pulse-0.9.5-0.5.svn20070924.fc9.i386
gstreamer-ffmpeg-0.10.4-1.lvn9.i386
gstreamer-tools-0.10.19-1.fc9.i386
gstreamer-plugins-bad-0.10.7-1.lvn9.i386
gstreamer-plugins-base-0.10.19-2.fc9.i386
gstreamer-plugins-good-0.10.8-1.fc9.i386
gstreamer-python-0.10.11-2.fc9.i386
gstreamer-plugins-ugly-0.10.8-1.lvn9.i386
gstreamer-plugins-flumpegdemux-0.10.15-2.fc9.i386
Comment 1 Matthias Saou 2008-07-25 05:33:41 EDT
FYI, I just had a similar problem. The fix was to add a gconf thumbnailer entry
for video@x-flv instead of the existing video@flv (without the "x-"). Details
can be found in this similar report :

http://bugs.archlinux.org/task/10802
Comment 2 Fedora Update System 2008-07-25 06:41:50 EDT
totem-2.23.2-6.fc9 has been submitted as an update for Fedora 9
Comment 3 Fedora Update System 2008-07-30 16:01:35 EDT
totem-2.23.2-6.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update totem'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6780
Comment 4 William Lovaton 2008-07-30 21:45:20 EDT
I just tested the update and it works for me now.  Thanks a lot!.
Comment 5 Fedora Update System 2008-09-24 16:03:22 EDT
xulrunner-1.9.0.2-1.fc9,firefox-3.0.2-1.fc9,blam-1.8.5-2.fc9,cairo-dock-1.6.2.3-1.fc9.1,chmsee-1.0.1-5.fc9,devhelp-0.19.1-4.fc9,epiphany-2.22.2-4.fc9,epiphany-extensions-2.22.1-4.fc9,evolution-rss-0.1.0-3.fc9,galeon-2.0.5-3.fc9,gnome-python2-extras-2.19.1-18.fc9,gnome-web-photo-0.3-14.fc9,google-gadgets-0.10.1-5.fc9,gtkmozembedmm-1.4.2.cvs20060817-21.fc9,kazehakase-0.5.5-1.fc9.1,Miro-1.2.4-3.fc9,mozvoikko-0.9.5-3.fc9,mugshot-1.2.2-2.fc9,ruby-gnome2-0.17.0-2.fc9,totem-2.23.2-7.fc9,yelp-2.22.1-5.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/xulrunner-1.9.0.2-1.fc9,firefox-3.0.2-1.fc9,blam-1.8.5-2.fc9,cairo-dock-1.6.2.3-1.fc9.1,chmsee-1.0.1-5.fc9,devhelp-0.19.1-4.fc9,epiphany-2.22.2-4.fc9,epiphany-extensions-2.22.1-4.fc9,evolution-rss-0.1.0-3.fc9,galeon-2.0.5-3.fc9,gnome-python2-extras-2.19.1-18.fc9,gnome-web-photo-0.3-14.fc9,google-gadgets-0.10.1-5.fc9,gtkmozembedmm-1.4.2.cvs20060817-21.fc9,kazehakase-0.5.5-1.fc9.1,Miro-1.2.4-3.fc9,mozvoikko-0.9.5-3.fc9,mugshot-1.2.2-2.fc9,ruby-gnome2-0.17.0-2.fc9,totem-2.23.2-7.fc9,yelp-2.22.1-5.fc9
Comment 6 Fedora Update System 2008-09-28 14:39:27 EDT
xulrunner-1.9.0.2-1.fc9, firefox-3.0.2-1.fc9, blam-1.8.5-2.fc9, cairo-dock-1.6.2.3-1.fc9.1, chmsee-1.0.1-5.fc9, devhelp-0.19.1-4.fc9, epiphany-2.22.2-4.fc9, epiphany-extensions-2.22.1-4.fc9, evolution-rss-0.1.0-3.fc9, galeon-2.0.5-3.fc9, gnome-python2-extras-2.19.1-18.fc9, gnome-web-photo-0.3-14.fc9, google-gadgets-0.10.1-5.fc9, gtkmozembedmm-1.4.2.cvs20060817-21.fc9, kazehakase-0.5.5-1.fc9.1, Miro-1.2.4-3.fc9, mozvoikko-0.9.5-3.fc9, mugshot-1.2.2-2.fc9, ruby-gnome2-0.17.0-2.fc9, totem-2.23.2-7.fc9, yelp-2.22.1-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.