Bug 449282 - System Config Network on opening
System Config Network on opening
Status: CLOSED DUPLICATE of bug 461115
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
9
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-01 13:08 EDT by Dave
Modified: 2008-11-28 10:46 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-28 10:46:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The attachment is a crash dump (2.56 KB, application/octet-stream)
2008-06-01 13:08 EDT, Dave
no flags Details

  None (edit)
Description Dave 2008-06-01 13:08:51 EDT
Component: system-config-network
Version: 1.5.10
Summary: TB57735b68 connection.py:607:call_blocking:DBusException:
org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Hal was not
provided by any .service files

Traceback (most recent call last):
  File "/usr/sbin/system-config-network-gui", line 166, in runit
    window = mainDialog()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
275, in __init__
    self.load()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
300, in load
    self.loadHardware()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
312, in loadHardware
    hardwarelist = getHardwareList()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line
759, in getHardwareList
    __HWList.load()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line
603, in load
    self.updateFromSystem()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line
483, in updateFromSystem
    self.updateFromHal(hdellist)
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line
447, in updateFromHal
    hal = NCBackendHal.NCBackendHal()
  File "/usr/share/system-config-network/netconfpkg/NCBackendHal.py", line 31,
in __init__
    self.halManagerObj = self._dbusBus.get_object("org.freedesktop.Hal",
"/org/freedesktop/Hal/Manager")
  File "/usr/lib/python2.5/site-packages/dbus/bus.py", line 244, in get_object
    follow_name_owner_changes=follow_name_owner_changes)
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 241, in __init__
    self._named_service = conn.activate_name_owner(bus_name)
  File "/usr/lib/python2.5/site-packages/dbus/bus.py", line 183, in
activate_name_owner
    self.start_service_by_name(bus_name)
  File "/usr/lib/python2.5/site-packages/dbus/bus.py", line 281, in
start_service_by_name
    'su', (bus_name, flags)))
  File "/usr/lib/python2.5/site-packages/dbus/connection.py", line 607, in
call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name
org.freedesktop.Hal was not provided by any .service files

Local variables in innermost frame:
byte_arrays: False
self: <dbus._dbus.SystemBus (system) at 0xa046ecc>
args: ('org.freedesktop.Hal', 0)
utf8_strings: False
bus_name: org.freedesktop.DBus
get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
object_path: /org/freedesktop/DBus
timeout: -1.0
signature: su
dbus_interface: org.freedesktop.DBus
message: <dbus.lowlevel.MethodCallMessage object at 0x9f7d4f0>
method: StartServiceByName
Comment 1 Dave 2008-06-01 13:08:51 EDT
Created attachment 307315 [details]
The attachment is a crash dump
Comment 2 Harald Hoyer 2008-06-11 07:43:20 EDT
hal should be installed and running!

$ rpm -qf /etc/rc.d/init.d/haldaemon 
hal-0.5.11-1.fc9.i386

$ /sbin/chkconfig --list haldaemon 
haldaemon      	0:off	1:off	2:off	3:on	4:on	5:on	6:off
Comment 3 Harald Hoyer 2008-06-11 07:43:43 EDT
can you check your system?
Comment 4 Antonio J. de Oliveira 2008-07-17 04:24:05 EDT
Hello, I'm running core 8 and have the same problem since the last upgrade.

haldaemon refuses to start, and this affects system-config-network as well as
sound system, I can only run oss, not alsa.

kernel is 2.6.25.10-47.fc8

this is a severe bug
Comment 5 Antonio J. de Oliveira 2008-07-22 07:03:18 EDT
it seems a duplicate of #455577
Comment 6 Jiri Moskovcak 2008-11-28 10:46:47 EST

*** This bug has been marked as a duplicate of bug 461115 ***

Note You need to log in before you can comment on or make changes to this bug.