Bug 449293 - Dovecot need rebuild against current fc9 openldap and openssl
Dovecot need rebuild against current fc9 openldap and openssl
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dovecot (Show other bugs)
9
All Linux
high Severity high
: ---
: ---
Assigned To: Dan Horák
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-01 17:30 EDT by Gwyn Ciesla
Modified: 2008-06-02 09:21 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-02 09:21:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gwyn Ciesla 2008-06-01 17:30:26 EDT
Current 1.0.13-6-fc9 requires libldap-2.3-so.0, libiber-2.3-so.0 and
libssl.so.6.  Rebuild fixes this.  Symlinking does not correct the issue.

openldap-2.4.8-3.fc9.i386
openssl-0.9.8g-6.fc9.i686
Comment 1 Gwyn Ciesla 2008-06-01 17:51:56 EDT
There might also be a yum or rpm issue, since the dovecot package requires the
above 2.3 libs, and yum did the upgrade anyway.  
Comment 2 Dan Horák 2008-06-02 03:48:44 EDT
This is on fresh install of F-9 or an upgrade from previous version?
Can you point me to the package that says it depends on the old libs?
What does "ldd /usr/libexec/dovecot/dovecot-auth" say?

I have a fresh install of F-9 and there is no such problem.
Comment 3 Gwyn Ciesla 2008-06-02 09:21:43 EDT
f8->f9 yum upgrade.

Str0ange, the other 2 systems on which dovecot is installed to not show this
problem (only the one in production).  I think I have an rpmdb problem, as this
system's log contain lots of ts_done selinux errors.  I'll chase that down.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.