Bug 449298 - xpdf uses non-existing sizes of helvetica and courier fonts
xpdf uses non-existing sizes of helvetica and courier fonts
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xpdf (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-01 18:26 EDT by Haakon Riiser
Modified: 2008-07-03 23:41 EDT (History)
0 users

See Also:
Fixed In Version: 3.02-7.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-03 23:39:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Make xpdf use 11 point fonts instead of non-existing 12 point fonts (2.62 KB, patch)
2008-06-01 18:26 EDT, Haakon Riiser
no flags Details | Diff

  None (edit)
Description Haakon Riiser 2008-06-01 18:26:56 EDT
When running xpdf, I always get the following warnings:

Warning: Cannot convert string
"-*-helvetica-medium-r-normal-*-12-*-*-*-*-*-iso8859-1" to type FontStruct
Warning: Cannot convert string "-*-courier-medium-r-*-12-*-*-*-*-*-iso8859-1" to
type FontStruct

This is the same error as was fixed in bug 250709, but it has reappeared with
different fonts.  Doing xlsfonts | egrep -i
'(helvetica|courier)-medium-r.*iso8859-1' shows that point size 12 does not
exist in Fedora 9.  The closest sizes are 11 and 14.  The attached patch makes
xpdf use font size 11 for both helvetica and courier, which makes the problem go
away.

This problem has been verified on Fedora 9 x86-64 using xpdf 3.02-6.  It can be
reproduced every time by simply typing "xpdf".
Comment 1 Haakon Riiser 2008-06-01 18:26:56 EDT
Created attachment 307323 [details]
Make xpdf use 11 point fonts instead of non-existing 12 point fonts
Comment 2 Haakon Riiser 2008-06-11 09:01:50 EDT
Turns out that the 12 point fonts _do_ exist in Fedora 9 (in the 75 dpi
package), but they have to be installed manually:

yum install xorg-x11-fonts-ISO8859-1-75dpi

I withdraw my suggested patch since the problem lies in xpdf's RPM dependencies,
not in xpdf's source code.
Comment 3 Tom "spot" Callaway 2008-06-11 09:12:14 EDT
Ahh, okay. That makes a lot more sense. :) I'll fix that up.
Comment 4 Fedora Update System 2008-07-02 17:50:26 EDT
xpdf-3.02-7.fc8 has been submitted as an update for Fedora 8
Comment 5 Fedora Update System 2008-07-02 17:51:00 EDT
xpdf-3.02-7.fc9 has been submitted as an update for Fedora 9
Comment 6 Fedora Update System 2008-07-03 23:39:10 EDT
xpdf-3.02-7.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2008-07-03 23:41:34 EDT
xpdf-3.02-7.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.