Bug 449314 - aplay gets stuck after hibernate
aplay gets stuck after hibernate
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-06-02 02:23 EDT by Philip Ashmore
Modified: 2009-01-09 01:33 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-01-09 01:33:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
snapshot of kdbg's stack dump window #2 (35.58 KB, image/png)
2008-06-09 11:17 EDT, Philip Ashmore
no flags Details

  None (edit)
Description Philip Ashmore 2008-06-02 02:23:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20080416 Fedora/ Firefox/

Description of problem:
I'm using Fedora 8 installed from the KDE 3.5 CD and updated via yum.

When I boot my machine sound works fine, but after a hibernate cycle, the only input that causes a sound output is the microphone.

However aplay gets stuck trying to play a sound
    $ aplay /usr/share/sounds/alsa/Front_Center.wav

I attached to this with kdbg after
    # debuginfo-install alsa-utils
and obtained a stack dump - see the snapshot link below for your

This is related to

The snapshot of the kdbg window is

I removed as much of pulseaudio as I could just in case.
    $ rpm -qa|grep pulseaudio

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Hibernate
2. Resume
3. $ aplay /usr/share/sounds/alsa/Front_Center.wav

Actual Results:
aplay gets stuck

Expected Results:
I should have heard a sound followed by aplay completing execution.

Additional info:
Comment 1 Martin Stransky 2008-06-06 11:27:18 EDT
Could you check "aplay -D hw:0,0 /usr/share/sounds/alsa/Front_Center.wav" after
the hibernate? It will play sound directly on the sound hardware....
Comment 2 Philip Ashmore 2008-06-06 12:04:39 EDT
I ran it with and without "time" - the results were the same - no sound.
The mic still works although I suspect that this is because the sound data is
being routed through hardware - just a guess.

$ time aplay -D hw:0,0 /usr/share/sounds/alsa/Front_Center.wav
Playing WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little
Endian, Rate 48000 Hz, Mono
aplay: pcm_write:1266: write error: Input/output error

real    0m10.012s
user    0m0.004s
sys     0m0.007s
Comment 3 Martin Stransky 2008-06-09 06:33:45 EDT
Can you attach strace output of the "aplay -D hw:0,0
/usr/share/sounds/alsa/Front_Center.wav" after hibernate?
Comment 4 Philip Ashmore 2008-06-09 11:13:50 EDT
I ran kdbg aplay after hibernate and interrupted it while it paused.
See attachment to follow.
Comment 5 Philip Ashmore 2008-06-09 11:17:09 EDT
Created attachment 308693 [details]
snapshot of kdbg's stack dump window #2

After hibernate
kdbg aplay -D hw:0,0 /usr/share/sounds/alsa/Front_Center.wav
Comment 6 Martin Stransky 2008-06-17 08:20:02 EDT
Hm, seems to be kernel-related. Moving...
Comment 7 Bug Zapper 2008-11-26 05:48:31 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 8 Bug Zapper 2009-01-09 01:33:50 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.