Bug 449316 - thunderbird update 2.0.0.14-1.fc9 x86_64 always fails
thunderbird update 2.0.0.14-1.fc9 x86_64 always fails
Status: CLOSED DUPLICATE of bug 446351
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-02 02:45 EDT by Tobias Vogel
Modified: 2008-06-02 16:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-02 16:41:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tobias Vogel 2008-06-02 02:45:39 EDT
Description of problem:


Version-Release number of selected component (if applicable):
2.0.0.14-1.fc9 x86_64

How reproducible:
2.0.0.14-1.fc8 --> 2.0.0.14-1.fc9 update via yum or packagekit.
the update never applies, yum says 

Error unpacking rpm package thunderbird-2.0.0.14-1.fc9.x86_64
error: unpacking of archive failed on file
/usr/lib64/thunderbird-2.0.0.14/dictionaries: cpio: rename


Steps to Reproduce:
1. yum update thunderbird  OR  update using packagekit
  
Actual results:
failed
Comment 1 Martin Stransky 2008-06-02 06:46:57 EDT
Did you update from F8 to F9 by yum?
Comment 2 Tobias Vogel 2008-06-02 06:52:43 EDT
I downloaded the F9 DVD for my architecture and updated via the DVD-Installer
(Update-Mode).
Comment 3 David Reed 2008-06-02 10:26:37 EDT
I discovered and worked around this.  It has to do with the dictionaries moving
to myspell in the fc8-fc9 transition.

The fix is to "rm -rf /usr/lib64/thunderbird-2.0.0.14/dictionaries" before doing
the update.

If I were an rpm packaging expert, I'd provide a fix to the .fc9 package.

Here's the yum output that says that the rename of the dictionary tree fails:
-----------------------------------
# yum update
Loaded plugins: priorities, refresh-packagekit
fedora                                                   | 2.4 kB     00:00     
livna                                                    | 2.1 kB     00:00     
updates                                                  | 2.3 kB     00:00     
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package thunderbird.x86_64 0:2.0.0.14-1.fc9 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 thunderbird             x86_64     2.0.0.14-1.fc9   fedora             23 M

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total download size: 23 M
Is this ok [y/N]: y
Downloading Packages:
(1/1): thunderbird-2.0.0.14-1.fc9.x86_64.rpm             |  23 MB     00:05     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating       : thunderbird                                       [1/2] 
Error unpacking rpm package thunderbird-2.0.0.14-1.fc9.x86_64
error: unpacking of archive failed on file
/usr/lib64/thunderbird-2.0.0.14/dictionaries: cpio: rename

Updated: thunderbird.x86_64 0:2.0.0.14-1.fc9
Complete!
Comment 4 Matěj Cepl 2008-06-02 16:41:12 EDT

*** This bug has been marked as a duplicate of 446351 ***

Note You need to log in before you can comment on or make changes to this bug.