Bug 449338 - mozilla plugin config segfaults with -v argument
mozilla plugin config segfaults with -v argument
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nspluginwrapper (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-02 05:41 EDT by Alexander Boström
Modified: 2008-10-22 07:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-22 07:55:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Boström 2008-06-02 05:41:49 EDT
Description of problem:
mozilla-plugin-config requires the -v flag to wrap libflashplayer

Version-Release number of selected component (if applicable):
flash-plugin-9.0.124.0-1.el5
nspluginwrapper-0.9.91.5-21.el5
firefox-3.0-0.beta5.6.el5

How reproducible:
Always.

Steps to Reproduce:
# /usr/bin/mozilla-plugin-config -i -f -v >/dev/null 2>&1
# ls /usr/lib/mozilla/plugins-wrapped/libflashplayer.so
/usr/lib/mozilla/plugins-wrapped/libflashplayer.so

# /usr/bin/mozilla-plugin-config -i -f >/dev/null 2>&1
# ls /usr/lib/mozilla/plugins-wrapped/libflashplayer.so
ls: /usr/lib/mozilla/plugins-wrapped/libflashplayer.so: No such file or directory

# /usr/bin/mozilla-plugin-config -i -f -v >/dev/null 2>&1
# ls /usr/lib/mozilla/plugins-wrapped/libflashplayer.so
/usr/lib/mozilla/plugins-wrapped/libflashplayer.so
Comment 1 Martin Stransky 2008-06-02 06:01:25 EDT
Hmm, that's really strange. I'll try to reproduce it.
Comment 2 Alexander Boström 2008-06-05 10:10:42 EDT
Hmm... Without -v, I get:

31915 access("/usr/lib/nspluginwrapper/npconfig", X_OK) = 0
31915 clone(child_stack=0,
flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0xb7fd2708)
= 31919
31915 waitpid(31919,  <unfinished ...>
31919 execve("/usr/lib/nspluginwrapper/npconfig",
["/usr/lib/nspluginwrapper/npconfig"..., "-p"..., "nswrapper_32_32"..., "-d"...,
"/usr/lib/mozilla/plugins-wrapped"..., "-i"...,
"/usr/lib/mozilla/plugins/nphelix.so"...], [/* 46 vars */]) = 0
31919 brk(0)                            = 0x99e6000
...

With -v, this happens:

31895 access("/usr/lib/nspluginwrapper/npconfig", X_OK) = 0
31895 clone(child_stack=0,
flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0xb7f4e708)
= 31899
31895 waitpid(31899,  <unfinished ...>
31899 write(2, "INFO: ", 6)             = 6
31899 --- SIGSEGV (Segmentation fault) @ 0 (0) ---

So apparently it works when there's a segfault.

I'm trying to catch it in gdb but it's eluding me there.
Comment 3 Martin Stransky 2008-10-22 07:47:23 EDT
Actually the problem is that the -v argument causes plugin-config segfault....
Comment 4 Martin Stransky 2008-10-22 07:55:38 EDT
Fixed in Rawhide, wontfix for the current RHEL line.

Anyway, /usr/bin/mozilla-plugin-config -i -f is the right command, don't use -v on rhel-5. The wrapped plugins have "nswrapper_arch_arch" prefix, so the wrapped flash is  in nswrapper_32_32.libflashplayer.so file. (or nswrapper_32_64.libflashplayer.so for 32->64 direction)

Note You need to log in before you can comment on or make changes to this bug.