Bug 449375 - problems updating with zoneedit
Summary: problems updating with zoneedit
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ez-ipupdate
Version: 8
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Jeff Layton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-02 14:24 UTC by Martí­n Marqués
Modified: 2014-06-18 07:37 UTC (History)
1 user (show)

Fixed In Version: ez-ipupdate-3.0.11-0.18.b8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-30 11:13:47 UTC
Type: ---


Attachments (Terms of Use)

Description Martí­n Marqués 2008-06-02 14:24:46 UTC
Description of problem:

When trying to update agains my account on zoneedit I get:

Jun  2 09:05:33 linus ez-ipupdate[1939]: unknown return code: 301
Jun  2 09:05:33 linus ez-ipupdate[1939]: server response: Moved Permanently
Jun  2 09:05:33 linus ez-ipupdate[1939]: failed to update ppp0->xxx.xxx.xxx.xxx
(mydomainname.com.ar)

(IP and domain name altered)

Version-Release number of selected component (if applicable):

ez-ipupdate-3.0.11-0.17.b8.fc8

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jeff Layton 2008-06-02 17:47:05 UTC
Looks like zoneedit has moved their dyndns updating app from www.zoneedit.com to
dynamic.zoneedit.com. I'll see about patching it in the near future...


Comment 2 Jeff Layton 2008-06-02 17:54:25 UTC
As a workaround, you can set the "server" option to "dynamic.zoneedit.com".
We'll have to see about getting this fixed upstream. The package there hasn't
been updated since 2002 so I'm not sure how difficult that will be...



Comment 3 Martí­n Marqués 2008-06-02 19:19:39 UTC
For starters I think it's gonna be very difficult, gusnet.cx doesn't resolve. :-(

The fix should be straight forward, as the first lines of ez-ipupdate.c have
configuration constants that have, for example the zoneedit server and port.

Anyway I'll change the server option so that the IP is sent to the right server.

Thanks Jeff.

Comment 4 Martí­n Marqués 2008-06-02 19:31:38 UTC
OK, adding this line to each zone worked:

server=dynamic.zoneedit.com

Couldn't get it to work globally. I thought that adding this line to
/etc/ez-ipupdate.conf would make it work for all the zones in /etc/ez-ipupdate/
directory.

Anyway, it's working great.

Comment 5 Jeff Layton 2008-06-02 19:46:26 UTC
Good. When I get some time, I'll see if I can track down the ez-ipupdate author.

> I thought that adding this line to /etc/ez-ipupdate.conf would make it
> work for all the zones in /etc/ez-ipupdate/ directory.

Ahh nope... /etc/ez-ipupdate.conf probably should be eliminated now that the
init script properly handles multiple config files and daemons. You'll need to
add it to each ez-ipupdate config file.




Comment 6 Fedora Update System 2008-06-08 12:09:17 UTC
ez-ipupdate-3.0.11-0.18.b8.fc9 has been submitted as an update for Fedora 9

Comment 7 Fedora Update System 2008-06-08 12:09:54 UTC
ez-ipupdate-3.0.11-0.18.b8.fc8 has been submitted as an update for Fedora 8

Comment 8 Jeff Layton 2008-06-08 12:13:41 UTC
Had no luck getting in touch with the upstream maintainer. I've gone ahead and
committed a patch to fix the default, built a package and pushed it to
updates-testing. If you're able to test it, please get the package from here and
report the results:

https://admin.fedoraproject.org/updates/F8/pending/ez-ipupdate-3.0.11-0.18.b8.fc8

Comment 9 Fedora Update System 2008-06-10 03:13:33 UTC
ez-ipupdate-3.0.11-0.18.b8.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ez-ipupdate'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-5117

Comment 10 Fedora Update System 2008-06-18 03:14:39 UTC
ez-ipupdate-3.0.11-0.18.b8.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2008-06-18 03:16:14 UTC
ez-ipupdate-3.0.11-0.18.b8.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Martí­n Marqués 2008-06-30 10:44:15 UTC
Works OK.


Note You need to log in before you can comment on or make changes to this bug.