Bug 449379 - Print dialog submits job directly to remote IPP host; destroys job management
Print dialog submits job directly to remote IPP host; destroys job management
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
rawhide
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Marek Kašík
Fedora Extras Quality Assurance
:
Depends On: 248245
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-02 10:56 EDT by Tim Waugh
Modified: 2008-07-07 07:57 EDT (History)
0 users

See Also:
Fixed In Version: gtk2-2.13.2-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-07 07:57:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2008-06-02 10:56:47 EDT
Description of problem:
When printing a job to a queue that has an ipp: URI, the print dialog now
submits the job directly to the remote host.  This is incorrect, for many
reasons, most severe of which are:

1. This destroys job management.  The user can no longer see all their submitted
jobs in the print applet, or cancel any jobs that are to networked IPP printers,
or even remote CUPS servers.

2. Jobs can no longer be spooled for a network printer that is currently
switched off.

Version-Release number of selected component (if applicable):
gtk2-2.13.1-2.fc10

How reproducible:
100%

Steps to Reproduce:
1.Set up a network printer (perhaps a CUPS server).
2.Set the queue disabled, so that jobs are accepted but the queue is not run.
3.On a client machine, print to the discovered queue using gedit.
4.Now try to cancel the job.

Actual results:
It's really hard.

Expected results:
The method is *meant* to be:
1. Click the printer icon on the notification area
2. Select the job
3. Cancel it from the context menu

Additional info:
Still works fine in Fedora 9, gtk2-2.12.9-5.fc9.x86_64.
Comment 1 Tim Waugh 2008-06-02 11:06:00 EDT
Pretty sure this was caused by the patch for bug #248245, which looks wrong to me.
Comment 2 Marek Kašík 2008-06-13 04:48:44 EDT
Hi Tim,
I fixed this in gtk2-2.13.2-2 release of gtk2 (rawhide) and in gtk2-2.12.8-5
(Fedora 8).

  Thank you for reporting this

    Marek
Comment 3 Tim Waugh 2008-06-13 07:24:26 EDT
Looks fine here.

Note You need to log in before you can comment on or make changes to this bug.