This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 449388 - git should not require curl, only libcurl
git should not require curl, only libcurl
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: git (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Wright
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-02 11:39 EDT by Stepan Kasal
Modified: 2013-01-10 05:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-22 08:31:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stepan Kasal 2008-06-02 11:39:07 EDT
I was trapped today by the misdesign of curl command, see bug #449369.
So I'd like to remove curl (not libcurl) from my machine.

I cannot co that, because git requires it.  But it seems that git calls curl
only in two places: git-clone.sh and git-ls-remote.sh.  Couldn't these two be
rewritten so that libcurl would be enough for the whole git.

Yeah, this is an enhancement request and I'm not providing the patch (yet), sorry.
Comment 1 Stepan Kasal 2008-06-03 08:45:01 EDT
Additional info:
I mentioned the problem on the git list, and was assured that the last occurence
of "curl" command has been removed:
http://article.gmane.org/gmane.comp.version-control.git/83640

Consequently, when git-1.5.6 is released and accepted to Fedora, we can drop
"Require: curl" and perhaps replace "BuildReuire: curl-devel" by "BuildRequire:
libcurl-devel".
Comment 2 Josh Boyer 2008-10-22 08:31:51 EDT
Fixed in git-1.6.0.3-1

Note You need to log in before you can comment on or make changes to this bug.