Bug 449390 - Future Feature: Installation Guide clarification
Future Feature: Installation Guide clarification
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: readme-burning-isos (Show other bugs)
devel
All Linux
low Severity low
: ---
: ---
Assigned To: Zach Oglesby
eric@christensenplace.us
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-02 11:51 EDT by Bill Case
Modified: 2010-06-03 02:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-03 02:19:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Case 2008-06-02 11:51:20 EDT
Description of problem:
Copied from Fedora Users fedora-list@redhat.com

"I looked through the Release Notes and the Installation notes.  There is
no reassurance that for hard drive installation the CD and DVD isos are
equivalent and no clear statement on what to burn and use for starting
installation process."

"In F8, there was only the DVD iso, for those who didn't have a DVD r/w  a
rescue disk was made available that could be downloaded and burned.  When
booting it took you directly to an options screen for installing or rescuing --
no 'askmethod' involved."

"It only takes a line of explanation (or a link) about creating a boot
disk in the Installation Guide but some reassurance would have been --
well -- reassuring."

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.
  
Actual results:

Expected results:

Additional info:

My I suggest a Section 2.3a (i.e part of 2.3) in the Installation Guide a
listing of all the ways to prepare a boot/rescue disk if needed.

Example:

Preparing or burning a disk to begin installation
1) If you have downloaded and burnt the DVD or CDs iso images to disk, the DVD
or the first CD are sufficient to start the installation process.  If you start
from the CD disks you will need all 7 cds pre-burnt.  If you are using the DVD
everything you need for installation is on that disk.

2) If you are installing from a harddrive you will need and have down loaded the
DVD iso image, you can either burn the DVD (see 1)above)or download the rescue
disk iso image and burn that to a CD. Use the rescue disk to start the initial
installation boot. 

If you have downloaded the 7 CD iso images, burn the first (cd-whatever-#1)and
use that to start the initial installation boot. 

3) If you are installing from a network, do etc.

I have been using Fedora/Redhat for more that four years so a new installation
no longer frightens me.  But I am sure someone relatively new, who is probably
in silent fear of wiping out everything they have on the harddisk(s), blowing up
their computer and getting struck by lightning hurled at them by God, a little
reassurance that they are doing the right things goes a long way.

PS  Your explanation on how to burn a disk if you are in Windows is quite clear
but couldn't you add a quick refresher ( just a sentence or two) on how to burn
an iso image while in a version of Fedora/Linux.
Comment 1 Bill Case 2008-06-02 11:59:39 EDT
s/need and have down loaded the
DVD iso image, you/need the DVD iso image. You/

Somewhere in 2) should be a link, see 'askmethod'
Comment 2 David Nalley 2008-11-23 13:31:39 EST
Bill, 
Can you please let me know if you think the current iteration solves this issue: 
http://jsmith.fedorapeople.org/drafts/


I've reread this bug several times and it realistically looks like three issues: 

1. that the readme-burning-isos document had better linux support
2. that the install guide annotate that CDs and DVD are equivalent
3. a listing of all the ways to prepare a boot/rescue disk if needed.


Please let me know if I am wrong about this analysis. 
I personally think that #2 is accomplished in the current draft. 
I think #3 is really handled in burning isos, though with the advent of first aid kit we perhaps should revisit the rescue disk angle. 

#1 is a bit out of scope, but I'll be happy to look at the document and if necessary create another bug for that item.
Comment 3 Bill Case 2008-11-24 12:16:27 EST
Hi;  My key wording was for "reassurance".  That is, I upgrade to a new version only once every six months and other people may be doing it for the first time or from another distribution of Linux.  A user is about to wipe out his existing Linux system and wants to be reassured they have everything covered.   I have looked at the latest draft installation guide.

# 2 is well met in the current draft.

# 1 is not.  I merely meant that a there should be a line or sentence in the section on burning a disk to the effect that "If you are burning a disk(s) on a LINUX machine using Nero, follow the instructions below.  If you are using another ISO burner program such as cdrecord, gnome nautilus or Xroast check for the appropriate instructions in 'man' or 'help'."

The point being that burning LINUX ISO disks is recognized in this installation section as well as Windows.  It reassures the user that it is not necessary to go hunting for a different disk burning section for LINUX in the Guide and directs him where to look for further instructions if he/she has doubts.

As an additional prompt perhaps one of the first sentences in the disk burning section might say something like: "If you are planning on using the 'askmethod' to install from your hard disk either the first CD ISO image or the Rescue disk ISO image will have to be burnt to CD or DVD".

# 3 is no longer needed.  In Fc8, when I first initiated this bug, for some reason only the DVD version was downloadable for i86_64 to hard disk.  Figuring out how to start installation using the 'askmethod' with no extra install CD for those who had no DVD drive was difficult.

This is a long winded sample of what I mean.  If you can condense the same reassurances into just a few additional words rather than whole sentences that would be even better.

Regards Bill
Comment 4 Ruediger Landmann 2009-06-18 01:32:48 EDT
Of the three issues, the only one outstanding is against readme-burning-isos, not the install-guide. Therefore, I'm changing the component. Zach, I know that you're working on this right now.
Comment 5 Zach Oglesby 2009-06-20 11:36:03 EDT
Yeah I am currently working on a rewrite of readme-burning-iso that includes windows, linux, and osx.
Comment 6 Zach Oglesby 2010-06-03 02:19:08 EDT
Read-me-burning-iso now includes directions for Linux, OS X, and Windows. I am going to close this bug.

Note You need to log in before you can comment on or make changes to this bug.