Bug 449393 - Review Request: prism - make web apps standalone
Review Request: prism - make web apps standalone
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Tyler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-02 12:02 EDT by Peter Robinson
Modified: 2009-08-07 06:43 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-07 06:43:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ctyler.fedora: fedora‑review?


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2008-06-02 12:02:03 EDT
SPEC: http://fedora.roving-it.com/rawhide/prism.spec
SRPM: http://fedora.roving-it.com/rawhide/prism-0.9-0.1.cvs20080416.fc9.src.rpm

This is my first hack at getting prism for Fedora. The spec file is based on a
very hacked up copy of the firefox.spec file. It includes a full copy of the
mozilla source code (like xulrunner and firefox) as you need the mozilla build
system to be able to build it (see b.m.o # 381900 for details) and a horrid
install section as the mozilla build system returns "Prism can't be installed
directly." on a 'make install' although I can't be sure that's not due to my
patches to allow the build of prism without doing a full mozilla build. Loads of
feedback welcome :-)
Comment 1 Chris Tyler 2008-06-03 22:36:02 EDT
"gecko-devel-unstable" is a BuildRequires, but where is it?
Comment 2 Peter Robinson 2008-06-04 04:39:35 EDT
Not sure what you mean by "but where is it?". Do you mean where is the package,
where is it required as a BuildReq or something else?
Comment 3 Chris Tyler 2008-06-04 07:55:36 EDT
Sorry, Peter -- I meant that that "gecko-devel-unstable" doesn't seem to exist
in the Fedora universe. I tried building and it failed due to that BuildReq, and
I can't find that package in the repositories, Koji, or as a review request.
Building in mock with that line disabled fails.
Comment 4 Mamoru TASAKA 2008-06-04 08:24:49 EDT
gecko-devel-unstable is provided by xulrunner-devel-unstable,
only available on F-9+.
Comment 5 Peter Robinson 2008-06-04 08:32:06 EDT
Its provided by xulrunner-devel-unstable and is the naming convention that is
used by the firefox spec so that why I used it as opposed to 
xulrunner-devel-unstable

[root@euuklonw7300b1n ~]# yum whatprovides gecko-devel-unstable
Loaded plugins: refresh-packagekit, refresh-updatesd
xulrunner-devel-unstable.x86_64 : Development files for Gecko, which are not
considered stable
xulrunner-devel-unstable.x86_64 : Development files for Gecko, which are not
considered stable
Comment 6 Chris Tyler 2008-06-04 10:16:33 EDT
Build fails in mock with F9 profile. Adding BuildRequires for these packages
allows the mock build to succeed: python, gtk2-devel, dbus-glib-devel, libIDL-devel
Comment 7 Peter Robinson 2008-06-04 10:47:25 EDT
I thought there might be some BuildReq issues as I trimmed some of them out from
the original firefox spec as wasn't sure whether they'd be needed. Python's an
interesting one. Will update the spec soon. Thanks for the update.
Comment 8 David Humphrey 2008-06-04 10:55:37 EDT
The mozilla build system increasingly uses python (moz2 even more so), so not
that unusual.
Comment 9 Peter Robinson 2008-06-04 18:30:14 EDT
There is now a new prism.spec in the same location as the old one. I'm currently
having issue getting the new srpm up there. There's no others changes so it can
just go over the other one. I'll upload another srpm tomorrow when I have more
bandwidth.
Comment 10 Chris Tyler 2008-06-04 22:12:10 EDT
Will continue review when the srpm is up.
Comment 11 Peter Robinson 2008-06-05 05:10:48 EDT
New srpm and spec now both uploaded.
Comment 12 Chris Tyler 2008-06-05 13:44:17 EDT
rpmlint -v prism.spec:

  prism.spec:46: W: unversioned-explicit-provides webrunner

Mock build with F9 profile is successful (on x86_64). The generated package
doesn't run:

$ prism
/usr/bin/prism: line 181: /usr/lib64/prism-0.9/run-mozilla.sh: No such file or
directory
/usr/bin/prism: line 181: exec: /usr/lib64/prism-0.9/run-mozilla.sh: cannot
execute: No such file or directory

run-mozilla.sh is not included in the package:

$ rpm -ql prism | grep -c run-mozilla.sh
0
Comment 13 Peter Robinson 2008-06-09 04:33:14 EDT
There's another srpm/spec up now with the fix for run-mozilla.sh
 in.
Comment 14 Peter Robinson 2008-06-17 07:28:40 EDT
Updated to the latest svn snapshot. Chris did the last update fix the issue you
were seeing?

SPEC: http://fedora.roving-it.com/rawhide/prism.spec
SRPM: http://fedora.roving-it.com/rawhide/prism-0.9-0.2.cvs20080617.fc9.src.rpm
Comment 15 Chris Tyler 2008-06-22 22:32:03 EDT
Hi Peter -- sorry for the delay with this, I'm on the road back from FUDCon and
will continue the review when I get back to decent connectivity on Tuesday.
Comment 16 Peter Robinson 2008-06-23 04:57:18 EDT
No problems. Also I've seen a similar cpio md5 mismatch to the one below. I'm
not sure if its just my laptop or something else.

http://blogs.linux.ie/caolan/2005/02/23/cpio-md5-sum-mismatch/
Comment 17 Chris Tyler 2008-06-25 22:26:58 EDT
The package builds cleanly under mock and installs OK, but it doesn't seem to
*do* anything, whether invoked with a "-webapp ..." argument or without. I've
tested it on two x86_64 systems, each running F9 in a fairly clean
configuration, and get the same result on both: no UI appears, and no error
messages appear. mfinkle suggested running "xulrunner
/usr/lib64/prism-0.9/application.ini", but that produces the same effect.

The binary download from
http://people.mozilla.org/~mfinkle/prism/prism-0.9.en-US.linux-i686.tar.bz2 does
present a UI in a window.

Also, I am getting SELinux alerts when run in enforcing mode due to /tmp access.
Comment 18 Chris Tyler 2008-06-25 23:23:23 EDT
Additional info:

[B] is the binary download from pmo/~mfinkle (32 bit)
[F] is the fedora package (64 bit)
xulrunner[B]+application.ini[F] does not work
xulrunner[F]+application.ini[B] does work
xulrunner[F]+application.ini[F] does not work
xulrunner[B]+application.ini[B] does work
Comment 19 Peter Robinson 2008-07-18 06:02:59 EDT
Yes, I'm seeing the same issues. Mozilla has a weird build system for this in
that there's no 'make install' equivalent. I'm looking into this and trying to
see where things go weird.
Comment 20 Peter Robinson 2008-07-21 12:18:07 EDT
SPEC: http://pbrobinson.fedorapeople.org/prism.spec
SRPM: http://pbrobinson.fedorapeople.org/prism-0.9-0.3.cvs20080717.fc9.src.rpm

I've been playing some more with the build but its still not perfect. Updated
srpms here. Issue seems to be with xul and the .jar packages.

Note You need to log in before you can comment on or make changes to this bug.