Bug 449402 - cookie blocking dialog isn't serialised any more
cookie blocking dialog isn't serialised any more
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
2Bupstreamed
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-02 12:16 EDT by Dave Jones
Modified: 2015-01-04 17:30 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-17 02:21:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
an image of how not to block cookies. (738.18 KB, image/jpeg)
2008-06-02 12:16 EDT, Dave Jones
no flags Details
options (45.10 KB, image/jpeg)
2008-07-30 02:37 EDT, Dave Jones
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 448438 None None None Never

  None (edit)
Description Dave Jones 2008-06-02 12:16:28 EDT
if a site wants to set 20 cookies, firefox now pops up 20 dialogs in parallel,
making the 'use my choice for all cookies for this site' tickbox pointless,
because you now have 20 dialogs to dismiss.
Comment 1 Dave Jones 2008-06-02 12:16:28 EDT
Created attachment 307385 [details]
an image of how not to block cookies.
Comment 2 Matěj Cepl 2008-07-01 11:01:36 EDT
Could I get an exact version number of the firefox package where you can
reproduce this issue, please?
Comment 3 Dave Jones 2008-07-01 11:11:37 EDT
firefox-3.0-1.fc9.x86_64
Comment 4 Matěj Cepl 2008-07-29 11:43:45 EDT
Sorry, could I get also some URL to reproduce this? I tried Manchaster Evening
News, but I haven't persuaded my Firefox to generate all those dialogs.
Comment 5 Dave Jones 2008-07-29 11:59:12 EDT
I can't remember which url the above image was from.  I've seen it happen
recently with others. I'll add it next time it happens.
Comment 6 Matěj Cepl 2008-07-29 12:21:11 EDT
Let's keep that NEEDINFO here.
Comment 7 Dave Jones 2008-07-29 21:18:37 EDT
ah, think I found a way to trigger it.
visit http://brajeshwar.com/2008/choose-linux-over-windows-vista/

when the first cookie dialog appears, hit escape.
then you'll get a bunch of dialogs all in parallel. (move the dialog window out
of the way to see the others).
Comment 8 Matěj Cepl 2008-07-30 02:21:03 EDT
That's weird -- I escaped the first one and then I just confirmed quite
reasonably looking ones (flickr and something else).

Could I get a screenshot of about:config page with filter set on "cookie" word,
please?

Thanks.
Comment 9 Dave Jones 2008-07-30 02:37:26 EDT
Created attachment 312963 [details]
options
Comment 10 Matěj Cepl 2008-07-30 03:44:25 EDT
The only difference I see is that I don't have at all
pref.privacy.disable_button_view_cookies. What happens when you toggle it?
Comment 11 Matěj Cepl 2008-08-17 02:21:19 EDT
Dave,

after couple of months living with cookie dialog switched on, I cannot than to agree that its UI is very broken. However, I am afraid, we don't have capacity to fix it ourselves I am afraid. I have found this lovely bug upstream (with reproducer which actually reproduces this for me pretty well) https://bugzilla.mozilla.org/show_bug.cgi?id=448438, so I am closing this bug as UPSTREAM.

Note You need to log in before you can comment on or make changes to this bug.