Bug 449451 - Inconsistant rendering and crashes while viewing a pdf
Inconsistant rendering and crashes while viewing a pdf
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-02 13:33 EDT by Bruno Wolff III
Modified: 2008-11-08 12:23 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-08 12:23:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2008-06-02 13:33:12 EDT
Description of problem:
I was looking at a PDF file (the leaked 4th ed monster manual) and evince was
occasionally reporting problems with a jpg image, occasionally crashing with a
segfault and fairly often misrendering (black instead of sections of an image)
the first page of the PDF file. This happened with both i386 on x86 and x86_64
versions of the program.

Version-Release number of selected component (if applicable):
evince-2.22.1.1-1.fc9.i386 and evince-2.22.1.1-1.fc9.x86_64

How reproducible:
A few restarts is usually enough to turn up problems.

Steps to Reproduce:
1. evince MonsterManual4ed.pdf
2.
3.
  
Actual results:
Some segfaults and misrendered images.

Expected results:
Normal behavior.

Additional info:
If you want a copy of the file to test with, contact me and I'll get you a copy
privately.
Comment 1 Bruno Wolff III 2008-09-14 00:52:58 EDT
So far evince-2.23.92-1.fc10.i386 seems to be working better. I haven't seen a crash yet (and would have expected to by now with the other version) and am not seeing error messages that I was seeing earlier in the terminal window. I don't guaranty that it is all fixed, but it seems noticeably better.
Comment 2 Bruno Wolff III 2008-11-08 12:23:32 EST
I haven't had this problem for a long time now, so I am going to close this out.

Note You need to log in before you can comment on or make changes to this bug.