Bug 449453 - crashed on launch
crashed on launch
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
9
i686 Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-02 13:43 EDT by Beartooth Bugzapper
Modified: 2008-07-03 17:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-10 14:48:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
second bugbuddy result of trying to open PackageKit (231.73 KB, text/plain)
2008-06-02 14:33 EDT, Beartooth Bugzapper
no flags Details
From the first PkgKit crash (231.62 KB, text/plain)
2008-06-02 14:35 EDT, Beartooth Bugzapper
no flags Details
results of [root@hbsk ~]# /usr/sbin/packagekitd --verbose (13.08 KB, application/octet-stream)
2008-06-03 12:23 EDT, Beartooth Bugzapper
no flags Details
first crash (232.85 KB, text/plain)
2008-06-03 19:21 EDT, Beartooth Bugzapper
no flags Details
second crash (190.25 KB, text/plain)
2008-06-03 19:22 EDT, Beartooth Bugzapper
no flags Details
crash on attempt to update (221.96 KB, text/plain)
2008-06-04 10:42 EDT, Beartooth Bugzapper
no flags Details
New bug report, even though yum now works (231.64 KB, text/plain)
2008-06-07 11:21 EDT, Beartooth Bugzapper
no flags Details

  None (edit)
Description Beartooth Bugzapper 2008-06-02 13:43:24 EDT
From Bugzilla Helper:
User-Agent: Opera/9.27 (X11; Linux i686; U; en)

Description of problem:
I clicked on what used to launch pirut, and now says, in its properties, that it 
runs gpk-application (but rpm -q on both those names says not installed). It 
flashed an undersized window, too fast to see what it was, and then I got the 
bugbuddy box 

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Steps to Reproduce:
1.
2.
3.

Actual Results:
I saved gpk-application-bugreport.txt; but I don't see how to attach it here.

Expected Results:
It should have opened a window allowing me to add a/o remove packages.

Additional info:
System: Linux 2.6.25.3-18.fc9.i686 #1 SMP Tue May 13 05:38:53 EDT 2008 i686
X Vendor: The X.Org Foundation
X Vendor Release: 10499901
Selinux: Permissive
Accessibility: Disabled
GTK+ Theme: Nodoka
Icon Theme: Fedora

Memory status: size: 0 vsize: 0 resident: 0 share: 0 rss: 0 rss_rlim: 0
CPU usage: start_time: 0 rtime: 0 utime: 0 stime: 0 cutime:0 cstime: 0 timeout: 0 
it_real_value: 0 frequency: 0



----------- .xsession-errors ---------------------
XID: 67108898
[WARN 31459] polkit-error.c:143:polkit_error_get_error_message(): error != NULL

[There's lots more.]
Comment 1 Beartooth Bugzapper 2008-06-02 14:33:26 EDT
Created attachment 307547 [details]
second bugbuddy result of trying to open PackageKit
Comment 2 Beartooth Bugzapper 2008-06-02 14:35:03 EDT
Created attachment 307548 [details]
From the first PkgKit crash
Comment 3 Beartooth Bugzapper 2008-06-02 14:59:11 EDT
  Proper name is supposed to be gnome-packagekit, per Rahul Sundaram on Gmane's 
fedora.general list just now. My apologies for not finding that.

   I'll go try "gnome-packagekit &" as a root command, and see if that turns out 
any different, and report once more.

Comment 4 Beartooth Bugzapper 2008-06-02 15:07:29 EDT

[root@hbsk ~]# gnome-packagekit &
[1] 2071
[root@hbsk ~]# -bash: gnome-packagekit: command not found

[and there it sat, without returning a prompt. Trying from another terminal tab, I 
got : [btth@hbsk ~]$ su - 
Password: 
[root@hbsk ~]# ps ax|grep 2071
 2258 pts/3    S+     0:00 grep 2071
[root@hbsk ~]# ps ax|grep gnome-packagekit
 2264 pts/3    R+     0:00 grep gnome-packagekit
[root@hbsk ~]# 

   Meanwhile, I had tried to look for it in the gnome system monitor -- and 
clicking that launcher got another crash report, which it offered to send to 
Gnome; I concurred.



Comment 5 Robin Norwood 2008-06-02 15:17:55 EDT
The package name is 'gnome-packagekit', the executable name is
'gpk-application', so this is what you'd run from the commandline.  

The meat of the error seems to be:

[WARN 31459] polkit-error.c:143:polkit_error_get_error_message(): error != NULL
 Not built with -rdynamic so unable to print a backtrace
** (gpk-application:31459): WARNING **: Failed to initialize PolicyKit context:
(null)
[WARN 31459] polkit-error.c:156:polkit_error_free(): error != NULL

Comment 6 Beartooth Bugzapper 2008-06-02 15:39:50 EDT

[root@hbsk ~]# gpk-application &
[1] 3129
[root@hbsk ~]# 

    The return of proompt was immediate, and the app did launch. When I run it, 
however, it fetches all sorts of info -- but the Install or Remove button is 
grayed out.
Comment 7 Richard Hughes 2008-06-03 04:42:58 EDT
Sure, you're running this as root. Please see:
http://fedoraproject.org/wiki/PackageKitFaq
Comment 8 Beartooth Bugzapper 2008-06-03 10:46:37 EDT
   There's a misunderstanding here.

    I began trying root commands only *after* failure as user.

   When I log into F9 *as* *user* and click the launcher, it flashes a window for 
maybew two seconds, and then I get a bugbuddy report.

   If I try issuing commands *as* *user* through the CLI, they fail in different 
ways; but in any case, the app does *not* launch on this machine.

   In other words, it's completely unusable here.
Comment 9 Beartooth Bugzapper 2008-06-03 12:23:36 EDT
Created attachment 308261 [details]
results of [root@hbsk ~]# /usr/sbin/packagekitd --verbose


   This command is one of the suggestions on the packagekit site.
Comment 10 Beartooth Bugzapper 2008-06-03 12:32:29 EDT
   Example of CLI failure as user :


[btth@hbsk ~]$ /usr/sbin/packagekitd &
[1] 14671
[btth@hbsk ~]$ [WARN 14671] polkit-error.c:143:polkit_error_get_error_message(): 
error != NULL
 Not built with -rdynamic so unable to print a backtrace
[WARN 14671] polkit-error.c:156:polkit_error_free(): error != NULL
 Not built with -rdynamic so unable to print a backtrace
Error trying to start: Acquiring D-Bus name org.freedesktop.PackageKit failed due 
to security policies on this machine
This can happen for two reasons:
* The correct user is not launching the executable (usually root)
* The org.freedesktop.PackageKit.conf file is not installed in the system /etc/
dbus-1/system.d directory

    [It has hung there like that, with no return to prompt, for some hours now. 
And the app has not appeared.]
Comment 11 Robin Norwood 2008-06-03 14:40:35 EDT
Ok.  Well, you don't want to run packagekitd as a normal user (or at all, in the
normal course of events).  can you provide the same info from running
gpk-application or gpk-update-icon ?

Thanks.
Comment 12 Beartooth Bugzapper 2008-06-03 19:10:51 EDT
   In the normal course of events, I do indeed want to run it, long and hard. I 
don't trust anaconda's "customize now" in the slightest. (Last time, it installed 
literally dozens, plural, of things I had told it not to, and left other dozens 
uninstalled that I had told it to.)


Comment 13 Beartooth Bugzapper 2008-06-03 19:21:01 EDT
Created attachment 308302 [details]
first crash
Comment 14 Beartooth Bugzapper 2008-06-03 19:22:29 EDT
Created attachment 308303 [details]
second crash
Comment 15 Beartooth Bugzapper 2008-06-04 10:42:57 EDT
Created attachment 308347 [details]
crash on attempt to update


   After the crash, I tried yum update, and got "No packages marked for
update."
Comment 16 Beartooth Bugzapper 2008-06-07 11:21:43 EDT
Created attachment 308613 [details]
New bug report, even though yum now works


   Having run yum update successfully twice, I tried launching packagekit from
the panel again. No joy.
Comment 17 Robin Norwood 2008-06-09 12:53:03 EDT
Re: Comment #12 - I meant, as a normal user, you don't want to launch the
'packagekitd' program - it is a system daemon meant to be started by DBUS, not
something you'd launch from the commandline or anywhere else.  gpk-application
and other gpk-* programs are the ones you want to run.

We'll look into the crash you're getting, though.
Comment 18 Beartooth Bugzapper 2008-06-09 14:20:15 EDT
   OK, Many thanks; I'll be glad to try packagekikt again, when I can. It seems 
to show great promise, and I notice from Gmane's fedora.general list that it does 
work for other people. I trust bigzilla will continue to notify me of progress, 
unless I tell it otherwise.

   Meanwhile, reluctantly, I have yum-removed it, and installed synaptic instead, 
which I've never liked, but which does let me do the things I used to use pirut 
for (and can't do with yum).

   Thanks again, and strength to your arms!
Comment 19 Richard Hughes 2008-06-10 06:39:54 EDT
Do you have PolicyKit-gnome installed?
Comment 20 Beartooth Bugzapper 2008-06-10 11:35:14 EDT
   Sure enough! 

[btth@hbsk ~]$ rpm -q PolicyKit-gnome
PolicyKit-gnome-0.8-4.fc9.i386
[btth@hbsk ~]$ 

Want me to do "yum install gnome-packagekit" again before I use it? Or before & 
after? Or ...?
Comment 21 Richard Hughes 2008-06-10 11:56:02 EDT
If you want to help fix this bug then please reinstall PackageKit and
gnome-packagekit and then reboot. After you've rebooted, give the tools a go
just clicking them in the menus, and not logging in as root at all.
Comment 22 Beartooth Bugzapper 2008-06-10 12:49:47 EDT
   Done and done. By the tools I assume you mean the two just (re)installed -- or 
maybe  also the policy kit. In the menus, I found first an updater, whose 
preferences mention gpk; so I ran that first, having noticed an orange maple or 
sweetgum leaf with a bug on it; sure enough, that and a green one were in the 
popup. I set it running.

   I do  not find anything in the menu that seems to be the policy kit.

   The updater is downloading (It had offered 57 bugfixes and three other (green 
leaf) apps; it looks to be about 2/5 done so far.

   If it crashes, I'll report that; if not, I'll launch the package kit; if the 
launch succeeds, I'll find something to add and something to remove, and then 
report.
Comment 23 Beartooth Bugzapper 2008-06-10 14:20:04 EDT
   Nutshell : Triumph! aus voller Brust. Congratulations, and many many thanks!

   Details follow.

   The updater declared itself completed. The add/remove icon launched, downloaded 
admin tools for a long time, then got a pop-up saying "The group was not found. 
comps categories could not be loaded" -- but went on downloading, or seeming to, 
till I closed the pop-up.

   (I have only F9 and F9 Updates checked to use as sources.) I told it to 
refresh application lists, and it started downloading groups. (I seem to recall 
that refreshment being one of the undocumented requirements, or at least one I've 
never seen.)

   Presently it said it was finished, but showed me nothing. (No Filters is the 
setting everywhere.) Very strange : I always install an armload of admin tools, 
against the day I may need one.

   I tried Gnome. It started querying at once, and very quickly gave me a list.

    I highlighted atspi, which is installed; all four tabs showed things (and btw, 
these tabs are a great virtue, imnsho); and I decided too much other stuff that I 
use constantly required it; so I let it alone.

   avant-window navigator had a description beyond my ken; a good long list of 
files; dependencies of which I believe I have most, except for something involving 
bluetooth; and no apps liste under Required By. An ideal test, it seemed.

   Dillo couldn't show me its homepage, but only because that's an https; 
Epiphany did fine with it.

   So I told it to install. It demanded root's password, though in wording which 
seems to me apt to confuse the daylights out of anybody accustomed to Ubuntu; but 
I had been there before, and picked up on "the superuser"; so I gave it the right 
one.

    By the time I had typed that last paragraph, it was already done. Fast work!

    I tried the fedora gnome theme, which happened to have the Required By tab up. 
That took so long I tried a clicking a couple of the other tabs; that merely 
stopped everything. (It seems not to use multi-tasking here, for some reason you 
may understand, but I don't.) The list, when it came, had far more things than I 
wanted to have to put back.

   So I tried the gcalctool, which i keep installing, hoping to get around to 
trying it, and never have yet. That gave "No Packages" under Required By -- just 
what I wanted. I clicked remove.

   It resolved dependencies, tested something, removed, blanked the list of apps, 
queried, and restored it (back at the beginning, not at gcalctool), with gcalctool 
now showing a grayed out, sealed cardboard box.

   As a last test, in case it would show me anything, I ran yum update (finding 
nothing), and then yum install gcalctool -- which yum did, without protest. And I 
can open and tweak gcalctool, though only from the CLI. (Can't find it in Main 
Menu.)

   If anyone can think of any other tests, I'll be glad to try them. 

   Once again, whatever you did, CONGRATULATIONS, and many, many thanks!
Comment 24 Beartooth Bugzapper 2008-06-10 14:37:37 EDT
   PS : I just tried the admin tools again -- *after* remembering to first tell 
it to refresh. (Why doesn't it do that automatically?)

   It very quickly gave me a very long list. (My 1680x1050 screen can barely 
display all the letter A, even if I roll up the bottom panel.)
Comment 25 Robin Norwood 2008-06-10 14:48:12 EDT
Glad it's working for you now.
Comment 26 aravind.parchuri 2008-07-03 17:10:12 EDT
Reproduced on an F9 i386 machine. I am running gpk-application as a normal user,
and I haven't messed around with any daemons. It seems to be a random phenomenon
- once I reboot, it works a bunch of times, then starts segfaulting on launch.
Is there some crashed/exited daemon that gpk-application is trying to connect
to? I ran gpk-application inside gdb and got a backtrace, hope it helps:

[WARN 13416] polkit-error.c:143:polkit_error_get_error_message(): error != NULL
 Not built with -rdynamic so unable to print a backtrace

** (gpk-application:13416): WARNING **: Failed to initialize PolicyKit context:
(null)
[WARN 13416] polkit-error.c:156:polkit_error_free(): error != NULL
 Not built with -rdynamic so unable to print a backtrace

(gpk-application:13416): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(gpk-application:13416): GLib-GObject-CRITICAL **: g_signal_connect_data:
assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(gpk-application:13416): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(gpk-application:13416): GLib-GObject-CRITICAL **: g_signal_connect_data:
assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

Program received signal SIGSEGV, Segmentation fault.
0x0026ca3a in ?? () from /usr/lib/libpolkit-gnome.so.0
(gdb) 
(gdb) bt
#0  0x0026ca3a in ?? () from /usr/lib/libpolkit-gnome.so.0
#1  0x0026e930 in ?? () from /usr/lib/libpolkit-gnome.so.0
#2  0x001e7991 in ?? () from /lib/libgobject-2.0.so.0
#3  0x0026e99b in ?? () from /usr/lib/libpolkit-gnome.so.0
#4  0x001e80de in g_object_newv () from /lib/libgobject-2.0.so.0
#5  0x001e8cd2 in g_object_new_valist () from /lib/libgobject-2.0.so.0
#6  0x001e8e1e in g_object_new () from /lib/libgobject-2.0.so.0
#7  0x0026cfe8 in polkit_gnome_action_new_default ()
   from /usr/lib/libpolkit-gnome.so.0
#8  0x0804f939 in g_str_equal ()
#9  0x002024e3 in g_type_create_instance () from /lib/libgobject-2.0.so.0
#10 0x001e78a5 in ?? () from /lib/libgobject-2.0.so.0
#11 0x001e80de in g_object_newv () from /lib/libgobject-2.0.so.0
#12 0x001e8ca7 in g_object_new_valist () from /lib/libgobject-2.0.so.0
#13 0x001e8e1e in g_object_new () from /lib/libgobject-2.0.so.0
#14 0x0804c90e in g_str_equal ()
#15 0x0804c79f in g_str_equal ()
#16 0x0052e5d6 in __libc_start_main () from /lib/libc.so.6
#17 0x0804c5a1 in g_str_equal ()

Note You need to log in before you can comment on or make changes to this bug.