Bug 449459 - GFS2: kernel BUG at glock.c:487! wanted 0 got 1
GFS2: kernel BUG at glock.c:487! wanted 0 got 1
Status: CLOSED DUPLICATE of bug 447748
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
medium Severity high
: rc
: ---
Assigned To: Steve Whitehouse
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-02 14:23 EDT by Nate Straz
Modified: 2009-05-27 23:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-03 03:38:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nate Straz 2008-06-02 14:23:38 EDT
Description of problem:

While running through d_io w/ flocks on GFS2 w/ 1k file system blocks, one
node of four hit this panic:

GFS2: wanted 0 got 1
 G:  s:EX n:2/821cb f:lDp t:UN d:UN/3000 l:0 a:0 r:4
  I: n:22/532939 t:8 f:0x00000011
------------[ cut here ]------------
kernel BUG at /builddir/build/BUILD/gfs2-kmod-1.92/_kmod_build_/glock.c:487!
invalid opcode: 0000 [#1]
SMP 
last sysfs file: /devices/pci0000:00/0000:00:02.0/0000:01:1f.0/0000:03:02.1/irq
Modules linked in: sctp lock_dlm(U) gfs2(U) dlm configfs autofs4 hidp rfcomm
l2cap bluetooth sunrpc ipv6 xfrm_nalgo crypto_api dm_multipath video sbs
backlight i2c_ec button battery asus_acpi ac lp sg i2c_i801 e1000 floppy
e7xxx_edac i2c_core edac_mc ide_cd parport_pc pcspkr parport intel_rng cdrom
dm_snapshot dm_zero dm_mirror dm_mod qla2xxx scsi_transport_fc ata_piix libata
sd_mod scsi_mod ext3 jbd uhci_hcd ohci_hcd ehci_hcd
CPU:    1
EIP:    0060:[<f8d88632>]    Tainted: G      VLI
EFLAGS: 00010282   (2.6.18-92.el5 #1) 
EIP is at finish_xmote+0x188/0x250 [gfs2]
eax: 00000000   ebx: f2b4f77c   ecx: 00000046   edx: 00000000
esi: 00000000   edi: 00000001   ebp: 00000001   esp: f3dd4f40
ds: 007b   es: 007b   ss: 0068
Process glock_workqueue (pid: 2723, ti=f3dd4000 task=f7f1f000 task.ti=f3dd4000)
Stack: f8d9e234 00000000 00000001 f8d9cca0 f2b4f77c f2b4f784 f3095940 00000286 
       f8d88d9d f2b4f800 f2b4f804 f3095940 c04331de f8d88d7f f2b4f77c f3095954 
       f3095940 f309594c 00000000 c0433a92 00000001 00000000 c20136c4 00010000 
Call Trace:
 [<f8d88d9d>] glock_work_func+0x1e/0x92 [gfs2]
 [<c04331de>] run_workqueue+0x78/0xb5
 [<f8d88d7f>] glock_work_func+0x0/0x92 [gfs2]
 [<c0433a92>] worker_thread+0xd9/0x10b
 [<c042027b>] default_wake_function+0x0/0xc
 [<c04339b9>] worker_thread+0x0/0x10b
 [<c0435ea1>] kthread+0xc0/0xeb
 [<c0435de1>] kthread+0x0/0xeb
 [<c0405c3b>] kernel_thread_helper+0x7/0x10
 =======================
Code: 4b 24 eb 02 31 c9 89 f2 89 d8 e8 e4 00 00 00 e9 c8 00 00 00 57 ff 73 24 68
34 e2 d9 f8 e8 41 e0 69 c7 89 da 31 c0 e8 d4 f1 ff ff <0f> 0b e7 01 3a e1 d9 f8
83 c4 0c e9 a1 00 00 00 f0 0f ba 73 08 
EIP: [<f8d88632>] finish_xmote+0x188/0x250 [gfs2] SS:ESP 0068:f3dd4f40


Version-Release number of selected component (if applicable):
kernel-2.6.18-92.el5
kmod-gfs2-1.92-1.1.el5_2.2


How reproducible:
Unknown
Comment 1 Steve Whitehouse 2008-06-03 03:38:48 EDT
Until lock_dlm and dlm are fixed you will keep running into this.

*** This bug has been marked as a duplicate of 447748 ***

Note You need to log in before you can comment on or make changes to this bug.