This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 44946 - USB mouse is jittery under 2.4.5-0.2.9.
USB mouse is jittery under 2.4.5-0.2.9.
Status: CLOSED ERRATA
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Pete Zaitcev
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-18 20:32 EDT by Ed McKenzie
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-25 23:29:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Vojtech's fix (514 bytes, patch)
2001-06-20 20:49 EDT, Pete Zaitcev
no flags Details | Diff

  None (edit)
Description Ed McKenzie 2001-06-18 20:32:46 EDT
Description of Problem:
My USB mouse (Logitech MouseMan Wheel) is pretty frustrating to use under
2.4.5-0.2.9 -- it seems like it's dropping lots of events.  The cursor
jitters across the screen like it's OD'd on caffeine (it seems to be
jumping about on some kind of grid) and the wheel barely works at all.

How Reproducible:
100%.  The 2.4.5-0.2.9+xfs kernel in SGI's betatesting area behaves exactly
in the same way. 2.4.2-2 is a much more pleasant experience.

Steps to Reproduce:
1. Boot 2.4.5-0.2.9
2. Start X
3. Move the mouse around, and try scrolling in 

I was beginning to fear I my mouse was dying until I downgraded to 2.4.2-2. :)
Comment 1 Pete Zaitcev 2001-06-20 20:49:28 EDT
Created attachment 21425 [details]
Vojtech's fix
Comment 2 Pete Zaitcev 2001-06-20 20:50:41 EDT
Please try 2.4.5-1 as soon as it hits rawhide.
Comment 3 Pete Zaitcev 2001-06-25 16:44:45 EDT
Errata is out! Try 2.4.3-12, should work there.
ftp://ftp.redhat.com/pub/redhat/linux/updates/7.1/en/os/
Comment 4 Ed McKenzie 2001-06-25 18:23:24 EDT
Yep, the errata works.  Of course, if I weren't interested in playing with ext3, I wouldn't have been running 2.4.5 to begin with. (-:
Comment 5 Pete Zaitcev 2001-06-25 18:33:38 EDT
Oops, my mistake... What about the 2.4.5-1 Rawhide then?
I personally checked that the head CVS branch has the fix.
It is about time it worked its way into nightly builds.
Comment 6 Ed McKenzie 2001-06-25 23:18:00 EDT
Rawhide doesn't appear to have been updated for several days.  2.4.5-0.4 is
still the newest version available from rawhide.redhat.com.
Comment 7 Pete Zaitcev 2001-06-25 23:29:52 EDT
You are right, 2.4.5-1 did not make it. Let me investigate
how this pipeline works in more detail...
Comment 8 Ed McKenzie 2001-07-03 09:07:07 EDT
Fixed in 2.4.5-10.

Note You need to log in before you can comment on or make changes to this bug.