Bug 449586 - RHEL5: update ecryptfs-utils to latest
RHEL5: update ecryptfs-utils to latest
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ecryptfs-utils (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Karsten Hopp
: Rebase
Depends On:
Blocks: 445733 RHEL5u3_relnotes
  Show dependency treegraph
 
Reported: 2008-06-02 17:14 EDT by Eric Sandeen
Modified: 2009-01-20 16:59 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
The following caveats apply to this release of eCryptfs: Note that the eCryptfs file system will only work properly if the encrypted file system is mounted once over the underlying directory of the same name. For example: mount -t ecryptfs /mnt/secret /mnt/secret The secured portion of the file system should not be exposed, i.e. it should not be mounted to other mount points, bind mounts, and the like. eCryptfs mounts on networked file systems (e.g. NFS, Samba) will not work properly. This version of the eCryptfs kernel driver requires updated userspace, which is provided by ecryptfs-utils-56-4.el5 or newer. For more information about eCryptfs, refer to http://ecryptfs.sf.net. You can also refer to http://ecryptfs.sourceforge.net/README and http://ecryptfs.sourceforge.net/ecryptfs-faq.html for basic setup information.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:59:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sandeen 2008-06-02 17:14:50 EDT
RHEL5.2 has ecryptfs-utils-41 as tech preview; upstream has moved on to
ecryptfs-utils-45 with a handful of fixes, enhancements, and documentation
updates.  It seems reasonable to me to go ahead and pull in these upstream
changes for 5.3.

Thanks,

-Eric
Comment 1 Eric Sandeen 2008-06-02 17:18:24 EDT
(incidentally Mike, we should upate at least rawhide with this version first;
probably also F9, good to get that airtime on Fedora)

Thanks,
-Eric
Comment 2 RHEL Product and Program Management 2008-06-09 17:57:45 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Phil Knirsch 2008-06-13 09:24:19 EDT
This bug needs a review from the component owner before granting Devel ACK.

Thanks,

Read ya, Phil
Comment 4 Eric Sandeen 2008-06-27 16:30:45 EDT
Per the new kernel code I submitted today we need at least -44 for things to
keep working.  Mike had told me that there was a module param to keep using
netlink, but in fact miscdev is hard-coded, and we'll need -44 or greater.

Thanks,

-Eric
Comment 5 Jarod Wilson 2008-06-27 16:48:22 EDT
Looks like there's some good stuff we may well need/want for some of our own
userspace integration aspirations that'll be in ecryptfs-utils -50 or so (stuff
that just went in after -49 was tagged, plus some additional pending work).
Comment 9 Karsten Hopp 2008-08-14 08:28:33 EDT
version 56 has fixes for namespace problems as well as documentation fixes.
As some mount parameters have changed, most testcases need to be changed as well.
Comment 12 Don Domingo 2008-11-18 00:04:43 EST
this bug is now documented in the RHEL5.3 release notes. please refer to the following link within the next 24 hours or so to view the most current build:
http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.3/html-single/Release_Notes/
Comment 13 Don Domingo 2008-11-18 00:04:43 EST
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
eCryptfs is a stacked cryptographic file system for Linux. It mounts on individual directories in existing mounted lower file systems such as EXT3; there is no need to change existing partitions or file systems in order to start using eCryptfs. 
 With this release, eCryptfs has been re-based to upstream version 56, which provides several bug fixes and enhancements. In addition, this update provides a graphical program to help configure eCryptfs (ecryptfs-mount-helper-gui). 
 This update also changes the syntax of certain eCryptfs mount options. If you choose to update to this version of eCryptfs, you should update any affected mount scripts and /etc/fstab entries. For information about these changes, refer to man ecryptfs. 
 For more information about eCryptfs, refer to http://ecryptfs.sf.net. You can also refer to http://ecryptfs.sourceforge.net/README and http://ecryptfs.sourceforge.net/ecryptfs-faq.html for basic setup information.
Comment 17 Don Domingo 2008-11-24 18:17:33 EST
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1,4 +1,8 @@
-eCryptfs is a stacked cryptographic file system for Linux. It mounts on individual directories in existing mounted lower file systems such as EXT3; there is no need to change existing partitions or file systems in order to start using eCryptfs. 
- With this release, eCryptfs has been re-based to upstream version 56, which provides several bug fixes and enhancements. In addition, this update provides a graphical program to help configure eCryptfs (ecryptfs-mount-helper-gui). 
- This update also changes the syntax of certain eCryptfs mount options. If you choose to update to this version of eCryptfs, you should update any affected mount scripts and /etc/fstab entries. For information about these changes, refer to man ecryptfs. 
+The following caveats apply to this release of eCryptfs: 
+ Note that the eCryptfs file system will only work properly if the encrypted file system is mounted once over the underlying directory of the same name. For example: 
+mount -t ecryptfs /mnt/secret /mnt/secret
+ The secured portion of the file system should not be exposed, i.e. it should not be mounted to other mount points, bind mounts, and the like. 
+eCryptfs mounts on networked file systems (e.g. NFS, Samba) will not work properly. 
+ This version of the eCryptfs kernel driver requires updated userspace, which is provided by ecryptfs-utils-56-4.el5 or newer. 
+ The eCryptfs graphical user interface has been removed. 
  For more information about eCryptfs, refer to http://ecryptfs.sf.net. You can also refer to http://ecryptfs.sourceforge.net/README and http://ecryptfs.sourceforge.net/ecryptfs-faq.html for basic setup information.
Comment 23 Don Domingo 2008-11-27 16:51:14 EST
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -4,5 +4,5 @@
  The secured portion of the file system should not be exposed, i.e. it should not be mounted to other mount points, bind mounts, and the like. 
 eCryptfs mounts on networked file systems (e.g. NFS, Samba) will not work properly. 
  This version of the eCryptfs kernel driver requires updated userspace, which is provided by ecryptfs-utils-56-4.el5 or newer. 
- The eCryptfs graphical user interface has been removed. 
+ 
  For more information about eCryptfs, refer to http://ecryptfs.sf.net. You can also refer to http://ecryptfs.sourceforge.net/README and http://ecryptfs.sourceforge.net/ecryptfs-faq.html for basic setup information.
Comment 27 errata-xmlrpc 2009-01-20 16:59:59 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0203.html

Note You need to log in before you can comment on or make changes to this bug.