Bug 449630 - cpufreq can not work on Harwich platform
cpufreq can not work on Harwich platform
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.8
x86_64 Linux
high Severity medium
: rc
: 4.8
Assigned To: John Feeney
Martin Jenner
:
Depends On:
Blocks: 435614 450719 458123 461297
  Show dependency treegraph
 
Reported: 2008-06-02 17:56 EDT by Song, Youquan
Modified: 2013-01-10 02:03 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-20 06:32:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patches to fix acpi cpufreq driver load fail and cpu frequencey change fail (960 bytes, application/octet-stream)
2008-06-04 12:04 EDT, Song, Youquan
no flags Details

  None (edit)
Description Song, Youquan 2008-06-02 17:56:17 EDT
Description of problem:

cpufreq do not work on Harwich platform. Harwich (with 4x Xeon 3.2G, dual 
cores). BIOS verison: SHW40.86B.P.11.00.0070.121920060947


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. enable EIST in BIOS
2. boot RHEL4.7 
3. ls /sys/devices/system/cpu/cpu0/
cpu0 is empty directory.  
Actual results:


Expected results:


Additional info:
Comment 1 Song, Youquan 2008-06-04 12:04:20 EDT
Created attachment 308363 [details]
Patches to fix acpi cpufreq driver load fail and cpu frequencey change fail
Comment 2 Song, Youquan 2008-06-04 12:07:06 EDT
I backport a patche 
acpi_cpufreq_add_acpi_perf_data_and_software_coordination.patch can fix the 
bug. I valiate on Harwich platform, cpufreq work round with this patch.
Comment 3 John Villalovos 2008-06-11 15:01:01 EDT
Can you let me know where you backported the patch from?  What git commit had
this patch?
Comment 4 Song, Youquan 2008-06-12 04:02:28 EDT
RHEL4.7 kernel include a large patch to acpi-cpufreq driver(acpi.c) with the 
patch name: linux-2.6.9-x86-acpi-pstate.patch.  But kernel patch with this 
patch, has two bugs: 1)  acpi.ko fail to load because data->acpi_data is NULL 
pointer entry parameter in acpi_processor_register_performance function 
(acpi.c).  2) After fix the 1) bug, acpi.ko is load correctly, but the cpu 
frequencey can not be changed because the acpi.c do not record the the cpu 
depenedency for software coordination.  So, I fix these two bugs to enable 
acpi cpufreq driver.
After patch acpi_cpufreq_add_acpi_perf_data_and_software_coordination.patch to 
kernel-2.6.9-70ELsmp, the acpi-cpufreq can be loaded and cpu frequencey can be 
changed with workload change or user different setting on Harwich. 

The patch source codes include in acpi-cpufreq.c(acpi.c rename to acpi-
cpufreq.c), but these code include in different git commits.     
Comment 6 RHEL Product and Program Management 2008-09-03 09:00:10 EDT
Updating PM score.
Comment 7 John Villalovos 2008-12-10 11:50:33 EST
Youquan,
Is your last patch posted still current?  Just wondering if we need to update anything.


Matthew,
Is there anything else you need from Intel in order to fix this bug?
Comment 8 Song, Youquan 2008-12-11 03:10:00 EST
No change to the patches till now.
Comment 9 Matthew Garrett 2009-01-02 06:43:29 EST
I believe this to have been fixed by the patches from 458156 and 440267, which add the same code. See commits 13409a6d90bf438226518b6f453af56043aa75f9 and 970e6d7ee5faccb5e0fdfdd2288ad25ae8b3d9d7.
Comment 10 John Villalovos 2009-01-06 13:17:30 EST
Youquan,

Can you see if Bug 458156 and Bug 440267 have added the same code as your patches?
Comment 11 Song, Youquan 2009-01-07 03:07:43 EST
I can not access the bug 440267, so I can not check it. Can you grant me access priority?
Comment 12 Tony Camuso 2009-01-08 08:11:47 EST
Youquan,

Can you provide a Harwich for me to experiment with?

If there is one in RHTS, please reserve it and send me the root info.
Comment 13 Song, Youquan 2009-01-09 01:44:10 EST
Harwich truland, processor Xeon 7130 3.2GHz. 
BIOS: SHW40.86B.P.11.00.0070.121920060947
I am sure that RHTS has this machine.

Verify that 2.6.9-78.24.EL can fix this bug.  
The patches for Bug 458156 and Bug 440267 is mostly the same as my patch.
Comment 14 Tony Camuso 2009-01-14 13:50:54 EST
Youquan, 

Are you saying that 2.6.9-78.24 fixes the bug, or are you saying that you need it to be tested?
Comment 15 Song, Youquan 2009-01-14 20:52:01 EST
Yes. I mean that I verify that 2.6.9-78.24 fix the bug.
Comment 16 Luming Yu 2009-02-22 20:54:45 EST
Martin,
Are you going to verify if the bug really fixed?

Thanks,
Luming
Comment 18 Luming Yu 2009-03-11 02:04:40 EDT
I finally get access to a system from RHTS: intel-s3e8132-01.rhts.bos.redhat.com

It is said that this system could be Harwich...
With RHEL4.8 installed, there is still an empty /sys/devices/system/cpu/cpu0/
on this system.

I tried to check EIST in BIOS, but there are problems *unresolved* to do that through remote console just by pressing <DEL>. I'm working with RH trying to find a solution..
Comment 19 Luming Yu 2009-03-19 21:18:28 EDT
Thanks for John's great help, I got a Harwich..
I can see these info on harbinger.lab.bos.redhat.com.

[root@harbinger ~]# cat /proc/version 
Linux version 2.6.9-82.ELlargesmp (mockbuild@ls20-bc2-13.build.redhat.com) (gcc version 3.4.6 20060404 (Red Hat 3.4.6-10)) #1 SMP Wed Feb 25 12:57:24 EST 2009

[root@harbinger ~]# ls /sys/devices/system/cpu/cpu0/cpufreq/
affected_cpus		       scaling_available_governors  scaling_max_freq
cpuinfo_max_freq	       scaling_cur_freq		    scaling_min_freq
cpuinfo_min_freq	       scaling_driver		    scaling_setspeed
scaling_available_frequencies  scaling_governor


So, sounds like the symptom of the bug has gone with 2.6.9-92 kernel.

Note You need to log in before you can comment on or make changes to this bug.