Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 44965 - executable crashes with SIGILL
executable crashes with SIGILL
Status: CLOSED CURRENTRELEASE
Product: Red Hat Powertools
Classification: Retired
Component: crafty (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: bero
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-19 07:30 EDT by Emil Jerabek
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-17 10:24:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Emil Jerabek 2001-06-19 07:30:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.08 [en] (WinNT; I ;Nav)

Description of problem:
The crafty executable dies on SIGILL almost immediately after start.

How reproducible:
Always

Steps to Reproduce:
1.just run /usr/lib/crafty/crafty
2.
3.
	

Additional info:

Possible explanation: the Makefile in the corresponding SRPM forces everything to be compiled with "-march=i686",
even though the binary package is marked as "i386". After rebuilding with "-march=pentium" (which is the CPU I run it on), it 
seems to be OK.
Comment 1 Bernhard Rosenkraenzer 2002-01-17 11:19:44 EST
Since powertools has been discontinued, the official fix is the package removal.
Since you have found the way to fix it yourself, I'm not attaching a fixed package.

Note You need to log in before you can comment on or make changes to this bug.