Bug 449673 - New sections for Itanium support in the RH Virtualization Guide
New sections for Itanium support in the RH Virtualization Guide
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Virtualization_Guide (Show other bugs)
5.2
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Christopher Curran
Don Domingo
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-02 20:15 EDT by Michael Hideo
Modified: 2010-10-22 21:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: 5.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-12 14:22:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Hideo 2008-06-02 20:15:53 EDT
Description of problem:

Here are some proposed changes for Itanium support.

In table 2.1 "Host and guest architecture compatibility"
which needs to be augmented as mentioned in an earlier IT w/ ia64 support info.
 The fully virtualized ia64 line should have a footnote which reads:

   * requires the guest firmware image, see section 4.2

In chapter 4.2 the section entitled "Installing Red Hat Virtualization with
yum"; at the end of this paragraph after the command example "To install the xen
and kernel-xen packages, run:

       # yum install xen kernel-xen"

add:

Full-virtualized guests on ia64 will also need the guest firmware image from the
supplementary installation DVD.
Alternatively it can be installed from RHN with yum:

       # yum install xen-ia64-guest-firmware


++++++++++++++++++++++++
To address elilo we propose a whole new chapter:


Chapter 25. Configuring ELILO (ia64)

ELILO is the bootloader on EFI-based systems, particularly ia64.
Like GRUB on i686 and x86_64 systems, ELILO allows the user to select which
installed kernel to load at system boot time. It also allows the user to pass
arguments to the kernel.  The ELILO configuration file (located in the EFI boot
partition and symlinked to /etc/elilo.conf) contains a list of global options
and image stanzas.  When you install the kernel-xen RPM, a post-installs script
adds the appropriate image stanza to elilo.conf.

The ELILO configuration file has two sections:

* Global options that affect the behavior of ELILO and all the entries. 
Typically there's no need to change these from the default values.

* Image stanzas that define a boot selection along with
 associated options.

Here is a sample image stanza in elilo.conf:

   image=vmlinuz-2.6.18-92.el5xen
           vmm=xen.gz-2.6.18-92.el5
           label=linux
           initrd=initrd-2.6.18-92.el5xen.img
           read-only
           root=/dev/VolGroup00/rhel5_2
           append="-- rhgb quiet"

The "image" line signals to ELILO that the following lines apply to a single
boot selection.  This stanza defines a hypervisor ("vmm"), initrd, and
command-line arguments ("read-only," "root" and "append") to the hypervisor and
kernel.  At the ELILO boot line, this stanza can be selected by the label "linux."

ELILO translates "read-only" to the kernel command-line option "ro", which
causes the root filesystem to be mounted read-only until the OS initscripts
remount it read-write.
Likewise ELILO copies the "root" line to the kernel command-line.
These are merged with the "append" line to build a complete
command-line:

   "-- root=/dev/VolGroup00/rhel5_2 ro rhgb quiet"

The double-dash in the command-line indicates the separator between hypervisor
arguments and kernel arguments.  In the example above, the hypervisor has no
arguments (this is typical) and the kernel receives the arguments following the
double-dash.
(In fact ELILO gives the entire command-line to the hypervisor, which then
divides the content and passes the kernel portion to the kernel.)

You can customize the hypervisor by inserting parameters to the left of the
double-dash.  The full list is available <a
href="http://tx.downloads.xensource.com/downloads/docs/user/#SECTION04130000000000000000">here</a>.
The most common parameters are:

   mem=xxx

       Set the hypervisor maximum RAM usage.  Any additional RAM in the system
will be ignored.  The parameter may be specified with a B, K, M or G suffix,
representing bytes, kilobytes, megabytes and gigabytes respectively.  The
default unit, if no suffix is specified, is kilobytes.

   dom0_mem=xxx

Set the amount of RAM to allocate to dom0.  The same suffixes are respected as
for the mem parameter above.
The default in Red Hat Enterprise Linux 5.2 on ia64 is 4G.

   dom0_max_vcpus=xxx

Set the number of CPUs to allocate to dom0.  The default
in Red Hat Enterprise Linux 5.2 on ia64 is 4.

   com1=<baud>,DPS,<io_base>,<irq>
  
Set the parameters for the first serial line, for example
com1=9600,8n1,0x408,5.  The io_base and irq can be omitted to leave them at
their standard defaults.
The baud can be "auto" to indicate the bootloader setting
should be preserved.  Normally com1 should be omitted
entirely since serial parameters can be set as global
options in ELILO, or even earlier in EFI configuration.

   com2=<baud>,DPS,<io_base>,<irq>

Set the parameters for the second serial line.  See com1 above.

   console=<specifier_list>

Comma-separated preference list for the Xen console.
Options include vga, com1 and com2.  Normally this setting should be omitted
since the hypervisor will attempt to inherit EFI console settings.

Here's an example modifying the original image stanza with some of the options
above:

   image=vmlinuz-2.6.18-92.el5xen
           vmm=xen.gz-2.6.18-92.el5
           label=linux
           initrd=initrd-2.6.18-92.el5xen.img
           read-only
           root=/dev/VolGroup00/rhel5_2
           append="dom0_mem=2G dom0_max_vcpus=2 --"

Additionally this example removes the kernel parameters "rhgb quiet" so that
kernel and initscript output are generated on the console.  Note the double-dash
remains so that the append line is correctly interpreted as hypervisor arguments.
Comment 1 Michael Hideo 2008-06-03 08:13:30 EDT
Target ETA for completion and republishing the Virtualization is June 5th.
Comment 2 Michael Hideo 2008-06-12 14:22:46 EDT
Verifying that content is publically available. Note that style sheet is missing
from the page and I will follow up a request to fix that separately.

http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.2/html/Virtualization/chap-Virtualization-Configuring_ELILO.html

Also it is on page 227
http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.2/pdf/Virtualization/Virtualization.pdf

Setting bug to resolved

Note You need to log in before you can comment on or make changes to this bug.