Bug 449677 - Partitioner doesn't resize the file system
Partitioner doesn't resize the file system
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
i686 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-02 21:01 EDT by Roberto Bechtlufft
Modified: 2008-08-04 11:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-04 11:59:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roberto Bechtlufft 2008-06-02 21:01:17 EDT
I'm not used to posting bugs, so if I do something wrong here, please bear with
me :-)

Description of problem:
During installation, I used the Anaconda partitioner to resize my home partition
(ext3). However, next time I booted the system I got an error stating that the
filesystem size and the partition size were incongruent. In a few words, the
partitioner resized the partition, but not the file system, and that caused
major data loss.

How reproducible: 
Try to shrink your home partition during Fedora 9 installation and cry in
despair :-)


Steps to Reproduce:
1. Run the Fedora 9 liveCD and choose to install it;
2. On the partitioner, choose to shrink your home partition and do it;
3. Reboot your system, and you'll be asked to run FSCK manually. It's no use.
  
Actual results:
That's it, major data loss.
Comment 1 Andy Lindeberg 2008-06-03 11:50:00 EDT
Can you give more detail about your partitioning layout and the steps you took
to resize your home partition? I'm attempting to reproduce the problem but can't
without that information.
Comment 2 Roberto Bechtlufft 2008-06-03 12:08:02 EDT
Here is some info: I have a 40 GB IDE HD, and three partitions on it: 

- sda1 (ext3, mounted as /, fedora 8 was installed on it, about 5GB); 
- sda5 (swap, 1GB) 
- sda6 (ext3, about 33GB)

I wanted to shrink sda6 to about 29GB, as my home partition had 6GB free. So i
resized sda6 to 29GB and created a new partition, sda7 ext3, where I installed
Fedora 9.

I used anaconda's  partitioner to do it, so I asked it to shrink sda6, checked
the resize option, the format checkbox was unchecked, as I wanted to keep my
home partition data.
Comment 3 Roberto Bechtlufft 2008-06-03 12:17:39 EDT
Is there a chance that maybe I tried to shrink sda6 more than I could?

Suppose sda6 was 30GB in size, and it had only 1GB of free space. If I had tried
to shrink it to 25GB, would I get a warning, or would the partitioner go ahead
and do it?
Comment 4 Chris Lumens 2008-07-21 14:55:18 EDT
If resize2fs reports any errors, we should be displaying an error dialog to the
screen with the title "Resizing Failed", and only giving you the option to exit
the installer.  We also write out /tmp/resize.out during installation with the
output, though that is probably not available.  I don't suppose anaconda gave
you any indication that anything was wrong during resizing?
Comment 5 Chris Lumens 2008-07-21 14:56:40 EDT
My implication here is that if resize2fs didn't give us an error (like, say,
you're trying to shrink to a size smaller than it can do) then there's nothing
we can do.
Comment 6 Roberto Bechtlufft 2008-07-22 08:58:43 EDT
Well, there were no error messages. It's weird, because I've been doing this
kind of thin in Linux for years... 

Note You need to log in before you can comment on or make changes to this bug.