Bug 449698 - [Chapter 19.1] Remote_Management.xml:
[Chapter 19.1] Remote_Management.xml:
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Virtualization_Guide (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Christopher Curran
Don Domingo
http://www.redhat.com/docs/en-US/Red_...
: Documentation
Depends On:
Blocks: 449674
  Show dependency treegraph
 
Reported: 2008-06-02 21:39 EDT by Michael Hideo
Modified: 2010-01-26 23:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-26 23:53:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Hideo 2008-06-02 21:39:37 EDT
http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.2/html/Virtualization/sect-Virtualization-Remote_management_of_virtualized_guests-Remote_management_with_ssh.html

 

instructions end early.  There needs to be some example of how to make use of
the stuff that was just explained, such as how to connect to those machines
using virt-manager
Comment 1 Christopher Curran 2008-06-04 22:09:05 EDT
this is certainly a bug for engineering. It's out of my domain knowledge.
Comment 2 Bill Burns 2008-10-22 09:15:19 EDT
Chris L can you help out Chris C with this one?
Comment 3 Cole Robinson 2008-10-27 16:36:59 EDT
Hi, not sure exactly what format the input should be in, so I'll just give examples of how to connect to remote systems using virt-manager and virsh.

Remote connections using SSH:

  virsh:
    Connecting to remote hosts is specified via the --connect option. 
    For ssh, this will look like:

    virsh --connect xen+ssh://username@hostname/

    For the docs, it probably makes sense to only give an example with the
    root username since regular user access isn't too useful.

  virt-manager:
    1) Start virt-manager
    2) Go to File->Open Connection
    3) Enter:
       Hypervisor->Xen,
       Connection->Remote tunnel over SSH,
       and enter the desired hostname, then click connection

Remote connections over TLS and SSL:

  virsh:
    The command will simply be

    virsh --connect xen://hostname/

    As the docs say, there is also pretty extensive info at http://libvirt.org/remote.html

  virt-manager:
    Same process as for SSH, except in Step 3 the user will select
    Connection->Remote SSL/TLS with x509 certificate
    
General:
   Should be noted that remote management isn't all encompassing.
   virt-manager for example makes a lot of assumptions that it is
   running on the local machine, such as file browsing. As such
   save, restore, and vm creation is not available over remote
   connections, but typical operations like start, stop, pause/unpause,
   and stats monitoring all work.

If there is anything else I can provide, let me know.
Comment 4 Christopher Curran 2009-12-02 00:46:00 EST
Marking as modified. This bug should be fixed in the guide from RHEL 5.4. Sections have been heavily cleaned up for translation during 5.4 development.

Chris

Note You need to log in before you can comment on or make changes to this bug.