Bug 449705 - Should Requires(pre): /bin/sed
Should Requires(pre): /bin/sed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: texinfo (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-02 21:46 EDT by Jeremy Katz
Modified: 2008-06-05 07:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-05 07:02:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2008-06-02 21:46:23 EDT
%post scriptlet calls sed but package doesn't require sed to be installed first
leading to noise in install.log
Comment 1 Vitezslav Crhonek 2008-06-03 04:53:08 EDT
Jeremy, please teach me, why it should be Requires(pre): /bin/sed, when sed is
actually used in %post? At the moment, there's Requires(post): /bin/sed, this is
wrong?
Comment 2 Jeremy Katz 2008-06-03 10:47:57 EDT
Whoops, yeah, I just typo'd.

The problem is actually that you've introduced a dependency loop.  Both sed and
info require each other to be installed first.  Given that the sed invocation
was added to fix something cosmetic, it should probably be removed or at least
just be
  [ -x /bin/sed ] && /bin/sed ...
without the requires
Comment 3 Vitezslav Crhonek 2008-06-04 09:51:07 EDT
OK, thanks for clarification.

Note You need to log in before you can comment on or make changes to this bug.