Bug 449732 - Printing to cups-pdf gets SELINUX denial, but prints anyway.
Printing to cups-pdf gets SELINUX denial, but prints anyway.
Status: CLOSED DUPLICATE of bug 448652
Product: Fedora
Classification: Fedora
Component: cups-pdf (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-03 04:31 EDT by Kevin R. Porter
Modified: 2008-06-08 13:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-08 13:50:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin R. Porter 2008-06-03 04:31:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b5) Gecko/2008043010 Fedora/3.0-0.60.beta5.fc9 Firefox/3.0b5

Description of problem:
Whenever I try to print anything to the "cups-pdf" print queue, I get the following SELINUX denial 6 times, but the PDF file gets created anyway.  I.e. the SELINUX denial is a nuisance but not fatal.

Summary:

SELinux is preventing sh (cups_pdf_t) "search" to ./nscd (nscd_var_run_t).

Detailed Description:

SELinux denied access requested by sh. It is not expected that this access is
required by sh and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

Sometimes labeling problems can cause SELinux denials. You could try to restore
the default system file context for ./nscd,

restorecon -v './nscd'

If this does not work, there is currently no automatic way to allow this access.
Instead, you can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                system_u:system_r:cups_pdf_t:s0-s0:c0.c1023
Target Context                system_u:object_r:nscd_var_run_t:s0
Target Objects                ./nscd [ dir ]
Source                        cups-pdf
Source Path                   /usr/lib/cups/backend/cups-pdf
Port                          <Unknown>
Host                          toaster
Source RPM Packages           bash-3.2-22.fc9
Target RPM Packages           
Policy RPM                    selinux-policy-3.3.1-55.fc9
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall_file
Host Name                     toaster
Platform                      Linux toaster 2.6.25.3-18.fc9.x86_64 #1 SMP Tue
                              May 13 04:54:47 EDT 2008 x86_64 x86_64
Alert Count                   6
First Seen                    Tue 03 Jun 2008 04:05:04 AM EDT
Last Seen                     Tue 03 Jun 2008 04:05:04 AM EDT
Local ID                      09a49cea-9724-4967-bb2d-d301cb86d8ef
Line Numbers                  

Raw Audit Messages            

host=toaster type=AVC msg=audit(1212480304.71:411): avc:  denied  { search } for  pid=19347 comm="sh" name="nscd" dev=md2 ino=16334891 scontext=system_u:system_r:cups_pdf_t:s0-s0:c0.c1023 tcontext=system_u:object_r:nscd_var_run_t:s0 tclass=dir

host=toaster type=SYSCALL msg=audit(1212480304.71:411): arch=c000003e syscall=42 success=no exit=-13 a0=0 a1=7fff3fb5af40 a2=6e a3=3e2eb67a70 items=0 ppid=19346 pid=19347 auid=4294967295 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=4294967295 comm="sh" exe="/bin/bash" subj=system_u:system_r:cups_pdf_t:s0-s0:c0.c1023 key=(null)




Version-Release number of selected component (if applicable):
cups-pdf-2.4.7-1.fc9

How reproducible:
Always


Steps to Reproduce:
1.log in
2. try to print anything to cups-pdf "printer".
3.

Actual Results:
PDF file gets created ok, but also get the AVC denial popup.

Expected Results:
PDF gets created without the SELINUX noise.


Additional info:
this system is fairly vanilla X86_64 fresh-install of F9 (Sulphur) on a Core-2-Duo E6700.    Searched the bugs for cups-pdf, and while I saw other selinux denials reported for cups-pdf, this one didn't match any of the ones already reported.

SELINUX == neighbor's barking dog at 3am... a pain in the ahhss, but I hope it discourages the real burglars?   8-P
Comment 1 Marcin 2008-06-08 06:53:08 EDT
confirmed on fresh x86 F9 installation
Comment 2 Remi Collet 2008-06-08 13:42:34 EDT
Well, i also confirm this AVC.

I must investigated on it.
Comment 3 Remi Collet 2008-06-08 13:50:56 EDT

*** This bug has been marked as a duplicate of 448652 ***

Note You need to log in before you can comment on or make changes to this bug.