Bug 449761 - rhn_register crashes in "/usr/share/rhn/up2date_client/tui.py"
rhn_register crashes in "/usr/share/rhn/up2date_client/tui.py"
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
5.4
All Linux
low Severity low
: rc
: ---
Assigned To: Pradeep Kilambi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-03 09:22 EDT by David Tonhofer
Modified: 2013-01-22 11:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 15:07:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Tonhofer 2008-06-03 09:22:34 EDT
Description of problem:

On a newly installed RHES5 system (long after firstboot), I start rhn_register.
Everything works fine up to the point where rhn_register tries to push
information about the host to the RHN (note that a host with the same name
already exists at the RHN as I'm actually trying to upgrade the machine from
RHES4 to RHES5 and I'm not sure whether I'm proceeding correctly, but that is
another problem). At some point during the push, the program stops:

[root@misato bin]# rhn_register
An error has occurred:
exceptions.AttributeError
See /var/log/up2date for more information

In /var/log/up2date, we see:

[Tue Jun  3 14:01:53 2008] rhn_register
Traceback (most recent call last):
  File "/usr/sbin/rhn_register", line 82, in ?
    app.run()
  File "/usr/share/rhn/up2date_client/rhncli.py", line 65, in run
    sys.exit(self.main() or 0)
  File "/usr/sbin/rhn_register", line 64, in main
    ui.main()
  File "/usr/share/rhn/up2date_client/tui.py", line 2011, in main
    tui.run()
  File "/usr/share/rhn/up2date_client/tui.py", line 1883, in run
    win = self.windows[index](self.screen, self)
  File "/usr/share/rhn/up2date_client/tui.py", line 1520, in __init__
    rw = ReviewWindow(self.screen, self.tui, reg_info)
  File "/usr/share/rhn/up2date_client/tui.py", line 1564, in __init__
    if self.tui.activate_result.getStatus() == \
exceptions.AttributeError: 'dict' object has no attribute 'getStatus'

But after that also:

[Tue Jun  3 14:09:43 2008] up2date logging into up2date server
[Tue Jun  3 14:09:44 2008] up2date successfully retrieved authentication token
from up2date server

Furthermore, trying to start rhn_register again yields:

Red Hat Network Location: https://xmlrpc.rhn.redhat.com/XMLRPC
RHN Login: mplify
System ID: ID-1012640252

So the problem is not "blocking"



Version-Release number of selected component (if applicable):

rhn-setup-0.4.17-8.el5 (to which rhn_register belongs)

or maybe 

yum-rhn-plugin-0.5.3-6.el5 (to which up2date belongs)
Comment 1 Pradeep Kilambi 2008-09-19 13:45:53 EDT
from what I see, the only time this could happen is if your client is not able to communicate with the server or if server is returning an error code other than 0 or 1. 

Multiple cases in which this could happen:

* It could be the installation number you entered or the rogId in an existing registration could not be validated.

* or while you were trying RHN was in an outage mode or your client could not communicate with RHN and caused an CommunicationError exception.


Could you give it a try again and see if this happens again? also make sure you're using the right installation number while activating your client.

Thanks,
Comment 2 David Tonhofer 2008-09-19 15:20:58 EDT
Hi,

The machine is currently correctly registered, so I think I cannot re-register it. I have a few RHEL4 machines that still have to be upgraded to RHEL5 (though I don't know when), so I can try then?
Comment 3 Clifford Perry 2009-02-24 14:41:55 EST
Hi there, 
Currently there is not enough information here for us to replicate and attempts so far have not been able too. 

If this is still an open issue for you, please open a support ticket giving
details and we can assist to investigate further. 

Regards,
Cliff
Comment 4 RHEL Product and Program Management 2009-02-24 15:07:32 EST
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.