Bug 449768 - Kickstart iSCSI installs fail
Kickstart iSCSI installs fail
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-03 10:00 EDT by Jarrod Johnson
Modified: 2008-10-27 11:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 11:53:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A failing kikstart file (614 bytes, application/octet-stream)
2008-06-03 10:00 EDT, Jarrod Johnson
no flags Details

  None (edit)
Description Jarrod Johnson 2008-06-03 10:00:12 EDT
Description of problem:
If attempting to install a server without local disk using the same kickstart
file that works for RHEL5.1, RHEL5.2, and Fedora 8, the installing system fails
to identify the disk.  Breaking into the shell shows that by the time I can
check it, it has found iSCSI device and made it sda.  I note that during the
process, iSCSI starts up, then terminates, then starts up again on the server
attempting to install.

Version-Release number of selected component (if applicable):
The version that shipped on Fedora 9 release media.

How reproducible:
About 95% of the time on at least x86_64 and ppc64 (I have seen it succeed once
or twice, but haven't recently).  It seems like a race condition, because I
can't think of anything different, but who really knows.

Steps to Reproduce:
1. Use RHEL5.2 or similar with tgtadm to create an iSCSI target suitable to
kickstart file
2. Start Fedora9 network install using attached kickstart file
3. It will stop claiming insufficient space for partitioning scheme
  
Actual results:
It won't install at all.

Expected results:
It would install.

Additional info:
Comment 1 Jarrod Johnson 2008-06-03 10:00:12 EDT
Created attachment 308237 [details]
A failing kikstart file
Comment 2 Hans de Goede 2008-09-10 16:43:13 EDT
I'm currently working on porting a bunch of RHEL-5 anaconda iscsi fixes to Fedora, I believe the not finding of the disk is fixed, but there are still other issues which make using iscsi not work out of the box (it works during the install, but not afterwards).

Once I've something which I think should work I'll drop you a note here and ask you to test it.
Comment 3 Hans de Goede 2008-10-27 11:53:41 EDT
Ok, so when mkinitrd 6.0.68-1, shows up in tomorrows rawhide, iscsi in Fedora should be in good shape. So I'm closing this. If you want to test iscsi please use either the upcoming F-10 preview release, or do a network based install of rawhide.

If you still have issues with tomorrows rawhide or the F-10 preview (not the beta but the preview!) then please reopen.

Note You need to log in before you can comment on or make changes to this bug.