Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 449839 - Podcast download location file chooser never set to correct directory
Summary: Podcast download location file chooser never set to correct directory
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: rhythmbox
Version: 9
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL: http://bugzilla.gnome.org/show_bug.cg...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-03 20:41 UTC by Michel Alexandre Salim
Modified: 2009-03-24 13:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-03-24 13:39:00 UTC
Type: ---


Attachments (Terms of Use)
Patches sources/rb-podcast-source.c to set file chooser correctly (582 bytes, patch)
2008-06-03 20:41 UTC, Michel Alexandre Salim
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 536500 0 None None None Never

Description Michel Alexandre Salim 2008-06-03 20:41:31 UTC
Description of problem:
The file chooser (Edit->Preferences->Podcasts, Download location) always
displays the current directory (the home directory if launched from the
application menu; otherwise, the current directory on the shell), rather than
the actual directory set in the gconf key.

This is because the file chooser was accessed using
gtk_file_chooser_set_current_folder_uri, but given a file path instead. The
boolean return value is never checked and thus the error escapes unnoticed.

Using gtk_file_chooser_set_current_folder rather than the _uri variant fixes
this.


Version-Release number of selected component (if applicable):
0.11.5-12

How reproducible:
Always

Steps to Reproduce:
1. Navigate to the Podcasts tab as described above
2. Note the download location listed in file chooser
3. Repeat, this time launching Rhythmbox from a different directory
  
Actual results:
File chooser shows the current working directory

Expected results:
File chooser shows the podcast download directory

Additional info:

Comment 1 Michel Alexandre Salim 2008-06-03 20:41:31 UTC
Created attachment 308288 [details]
Patches sources/rb-podcast-source.c to set file chooser correctly

Comment 2 Bastien Nocera 2008-06-04 12:08:31 UTC
You could also just have mentioned the upstream report.

Comment 3 Michel Alexandre Salim 2008-06-04 17:52:21 UTC
True, that was a bit of an overkill.

Comment 4 Michel Alexandre Salim 2008-07-15 19:56:21 UTC
Updated patch available upstream; on IRC the developer has vetted the new patch,
but unfortunately did not acknowledge it in bugzilla.

Comment 5 Michel Alexandre Salim 2008-08-01 16:28:44 UTC
Updated patch linked:
http://bugzilla.gnome.org/attachment.cgi?id=113097

Bastien, could you nag the upstream developers, or perhaps just apply the patch?
Upstream wants the podcast directory to be stored as a URI, the patch does that
(right now, and in Rawhide's 0.11.6, the directory is stored as a path but read
as a URI, which fails).

There's the small problem that existing Rhythmbox podcast users will have to
manually change their podcast directory once, but that's probably better than
adding a check in the code that automatically converts paths to URIs.


Comment 6 Bastien Nocera 2008-08-08 14:33:27 UTC
Being worked on upstream.

Comment 7 Bastien Nocera 2009-03-24 13:39:00 UTC
Was fixed upstream, and should be in our latest versions on F10 and rawhide.


Note You need to log in before you can comment on or make changes to this bug.