Bug 449845 - Clone Errata Page - list containing duplicate rows
Clone Errata Page - list containing duplicate rows
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Tomas Lestach
Martin Minar
http://<satellite>/rhn/errata/manage/...
:
Depends On:
Blocks: sat560-lowbug
  Show dependency treegraph
 
Reported: 2008-06-03 17:12 EDT by Partha Aji
Modified: 2016-07-03 20:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:53:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dup Data Screen shot (174.61 KB, image/png)
2008-06-03 17:12 EDT, Partha Aji
no flags Details

  None (edit)
Description Partha Aji 2008-06-03 17:12:59 EDT
Description of problem:

Issues related to the clone errata page
Clone Errata page seems to list duplicate data when the "Show errata which have
already been cloned"  is checked.


Version-Release number of selected component (if applicable): 510


How reproducible: always


Steps to Reproduce:
1. login to sat 
2. Click on Errata -> Clone Errata
3. Select a channel from the drop down "View errata potentially applicable to:" 
4. Select All  -> Clone Errata and confirm.
5. Click on Errata -> Clone Errata
6. Check "Show errata which have already been cloned"  
7. Hit View


  
Actual results:
Notice the duplicate data for previously cloned  errata. This leads to other
confusions when you do a select all and only half the items are listed as
selected from the list..

Expected results:
No duplicate rows... Accurate selection count

Additional info:
Comment 1 Partha Aji 2008-06-03 17:12:59 EDT
Created attachment 308290 [details]
Dup Data Screen shot
Comment 2 Brandon Perkins 2008-10-08 11:52:03 EDT
We will deal with this issue when this page is migrated from perl to java.
Comment 3 Tomas Lestach 2013-05-30 07:38:56 EDT
The page was migrated to java in the mean time and there're no more duplicate errata rows.

Switching to ON_QA to go through the QA.
Comment 5 Clifford Perry 2013-10-01 17:53:20 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.