Bug 449860 - Fails to install drivers after adding printer
Fails to install drivers after adding printer
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 449900
  Show dependency treegraph
 
Reported: 2008-06-03 18:46 EDT by Michael Dugger
Modified: 2008-07-08 22:51 EDT (History)
0 users

See Also:
Fixed In Version: 0.7.82.5-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-08 22:51:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Dugger 2008-06-03 18:46:49 EDT
Description of problem:
When adding a new printer (HP LaserJet 2420dn) many drivers that are not
currently installed are listed. It would be preferable if after entering the
make/model the user was warned of this and told that the driver would be
downloaded as part of the device install. The troubleshooter does this but it
would be much better to not run it at all.

Version-Release number of selected component (if applicable):

Name        : system-config-printer        Relocations: (not relocatable)
Version     : 0.7.82.3                          Vendor: Fedora Project
Release     : 2.fc9

How reproducible:
Add new printer, many drivers are not installed by default

Steps to Reproduce:
1. Add new printer, even if the driver doesn't exist sys-config-printer will try
to use it.
2. Print test page, a warning will pop up that there is a problem.
3. Using the troubleshooter will locate the driver.
Comment 1 Tim Waugh 2008-06-04 03:32:34 EDT
Actually what's meant to happen is that you should get a dialog asking to
install the package as soon as you add the printer queue.

It's quite expensive to determine whether extra packages are required for a
particular printer/driver combination, so we can't really do this check when
displaying the driver list.  However, it could be done as part of the
add-printer wizard after 'Next' has been clicked.
Comment 2 Tim Waugh 2008-06-04 03:38:58 EDT
OK, here's the reason that dialog didn't appear after installing the printer:

/usr/bin/gs: found
c2070: NOT found in /usr/bin:/bin
c2070 included in package c2070
Caught non-fatal exception.  Traceback:
File "./system-config-printer.py", line 4398, in on_btnNPApply_clicked
    self.checkDriverExists (name, ppd=checkppd)
File "./system-config-printer.py", line 4458, in checkDriverExists
    dialog = self.InstallDialog
AttributeError: NewPrinterGUI instance has no attribute 'InstallDialog'
Continuing anyway..
Comment 3 Tim Waugh 2008-06-04 04:09:44 EDT
Fixed upstream.
Comment 4 Tim Waugh 2008-06-04 04:12:00 EDT
I've filed bug #449900 for the enhancement of performing this check before the
printer is added.
Comment 5 Fedora Update System 2008-06-20 13:55:52 EDT
system-config-printer-0.7.82.4-1.fc9 has been submitted as an update for Fedora 9
Comment 6 Fedora Update System 2008-06-22 16:44:12 EDT
system-config-printer-0.7.82.4-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5604
Comment 7 Fedora Update System 2008-07-08 22:51:13 EDT
system-config-printer-0.7.82.5-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.