This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 449872 - [Patch] Bluetooth keyboard not reconnecting after powersave
[Patch] Bluetooth keyboard not reconnecting after powersave
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 427677 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-03 21:24 EDT by Jason Galarneau
Modified: 2008-07-03 23:40 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.6.25.9-76.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-02 02:34:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bluetooth wakeup patch (918 bytes, patch)
2008-06-19 18:55 EDT, Bastien Nocera
no flags Details | Diff

  None (edit)
Description Jason Galarneau 2008-06-03 21:24:46 EDT
Description of problem:
apple wireless keyboard is connected via a usb bluetooth dongle, able to
connect(shows in bonded devices) but does not type


Version-Release number of selected component (if applicable):
bluez-utils-3.30-2.fc9.x86_64
bluez-gnome-0.26-1.fc9.x86_64
Apple wireless keyboard model No:MB167LL/A
Bluetooth dongle: Trendnet TBW-101UB(ca)

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
device is discoverable/detected but won't work


Expected results:
can type with the keyboard


Additional info:
http://forums.fedoraforum.org/showthread.php?p=1023245#post1023245
Comment 1 Bastien Nocera 2008-06-04 08:06:27 EDT
Could you explain the exact steps to reproduce the problem, and let us know:
- the state of the power button (is the led flashing? is the led off?)
- whether the keyboard shows up in the input devices (in the bluetooth
preferences, select "input service", check the table underneath)
- whether the keyboard shows up as connected (there should be a funnel-like
device next to the rest of the icons in the table mentioned above).
Comment 2 Jason Galarneau 2008-06-04 14:16:19 EDT
well, I used this guide:
http://ubuntuforums.org/showthread.php?t=224673
yes the green LED if flashing, I presumed that was discovery mode
yes, it is there under input service
yes there is(i thought it was a plug), but just when its in discovery mode, or
when I'm pressing a key
Comment 3 Jason Galarneau 2008-06-04 17:09:42 EDT
well, I used this guide:
http://ubuntuforums.org/showthread.php?t=224673
yes the green LED if flashing, I presumed that was discovery mode
yes, it is there under input service
yes there is(i thought it was a plug), but just when its in discovery mode, or
when I'm pressing a key
Comment 4 Fabien Le Floc'h 2008-06-16 04:29:45 EDT
I have had lots of problems with Apple Bluetooth Keyboard (aluminium) and Fedora
as well. 

First connection issues can be solved by following Ubuntu guides. I have also a
post about it at
http://chasethedevil.blogspot.com/2008/06/fedora-linux-apple-bluetooth-keyboard.html

Even after following these guides, the keyboard disconnects regularly (it might
be because of the usb bluetooth key). The only way I found to have it work very
well was to patch the kernel using this patch:
http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-hardy.git;a=blobdiff;f=net/bluetooth/hidp/core.c;h=dfaef02ba7b49f9503b6ae796090b39f6cc59a08;hp=42dd2b972cbe630acbedfefc334263b07aeac60b;hb=3923c54f44b4e8d31118b8a8b096cc85013d859f;hpb=97ea54575ec58a5bcf13ccf20556f4e68d961bf1

(lines change but it is very simple to adapt to Fedora latest kernel).
Comment 5 Bastien Nocera 2008-06-19 18:55:52 EDT
Created attachment 309889 [details]
Bluetooth wakeup patch

Original patch:
http://article.gmane.org/gmane.linux.bluez.devel/15745

This is required for Bluetooth keyboard and mice, as otherwise they won't be
able to reconnect automatically to the computer after being unused for a while.
Comment 6 Bastien Nocera 2008-06-19 18:58:27 EDT
FWIW, I've asked Marcel to commit it to his tree, but I think it's going to have
to wait until he finishes his work on Simple Pairing. He wrote the original patch.
Comment 7 Bastien Nocera 2008-06-25 05:55:26 EDT
*** Bug 427677 has been marked as a duplicate of this bug. ***
Comment 8 Bastien Nocera 2008-06-25 05:58:15 EDT
Updated patch:
http://git.kernel.org/?p=linux/kernel/git/holtmann/bluetooth-2.6.git;a=commitdiff_plain;h=97b8120e3ad27520bbd9b4e48f2dc08f9cd0037a

Could one of the kernel maintainers please push this?
Comment 10 Bastien Nocera 2008-06-27 13:45:44 EDT
I blame git.
Thanks Chuck.
Comment 11 Chuck Ebbert 2008-06-27 14:53:19 EDT
In 2.6.25.9-75
Comment 12 Fedora Update System 2008-06-30 12:34:00 EDT
kernel-2.6.25.9-76.fc9 has been submitted as an update for Fedora 9
Comment 13 Fedora Update System 2008-07-01 01:28:27 EDT
kernel-2.6.25.9-76.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5893
Comment 14 Fedora Update System 2008-07-02 02:34:39 EDT
kernel-2.6.25.9-76.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2008-07-03 23:40:15 EDT
kernel-2.6.25.9-76.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.