This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 449881 - Add OnlyShowIn=KDE; to ksysguard.desktop
Add OnlyShowIn=KDE; to ksysguard.desktop
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-03 23:34 EDT by Michel Alexandre Salim
Modified: 2008-06-04 04:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-04 04:38:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2008-06-03 23:34:46 EDT
Description of problem:
ksysguard.desktop is not restricted to KDE only, meaning it shows up when the
user is running GNOME. Most confusingly, both ksysguard and GNOME System Monitor
shows in the menu as "System Monitor" with the same icon.

Considering Xfce also has its own system monitor, perhaps ksysguard should only
be shown on KDE?

Version-Release number of selected component (if applicable):
4.0.80-2

How reproducible:
Always

Steps to Reproduce:
1. Log into GNOME
2. Applications->System Tools->System Monitor
  
Actual results:
There are two System Monitors

Expected results:
In GNOME, only the GNOME System Monitor should show up

Additional info:
This probably affects kdebase-workspace as shipped in Fedora 9 too.
Comment 1 Kevin Kofler 2008-06-04 03:49:33 EDT
IMHO the real bug is that it has a generic name in the Name field. That's not 
something KDE apps are supposed to do (or any apps, really, but especially not 
KDE apps because KDE handles GenericName properly).

If we change this to:
Name=KSysGuard
GenericName=System Monitor
(and adjust the translations accordingly), do you still want it OnlyShowIn=KDE?
Comment 2 Ngo Than 2008-06-04 04:33:10 EDT
If Gnome or other Desktop Enviroment has own Sytem Monitor, it doesn't make
sense to show KSysGuard in there or backwards we don't want the GNOME System
Monitor or similar to show in KDE menu!

We should add OnlyShowIn=KDE

Note You need to log in before you can comment on or make changes to this bug.