Bug 449884 - Fedora 9 Connecting Problem with Reliance ZTE MG880 and Huawei EC325 modems
Fedora 9 Connecting Problem with Reliance ZTE MG880 and Huawei EC325 modems
Status: CLOSED DUPLICATE of bug 467004
Product: Fedora
Classification: Fedora
Component: ppp (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Skala
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 01:15 EDT by Bala Krishnamurthy
Modified: 2014-11-09 17:31 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-12 01:56:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg output (24.21 KB, text/plain)
2008-06-26 05:09 EDT, Bala Krishnamurthy
no flags Details
Output of /var/log/messages (943.50 KB, text/plain)
2008-06-26 05:11 EDT, Bala Krishnamurthy
no flags Details

  None (edit)
Description Bala Krishnamurthy 2008-06-04 01:15:54 EDT
Description of problem: <Apparently at least a few others facing same problem>

I had both ZTE MG880 and Huawei EC325 modems working with Fedora Core 6. Service
provider Reliance, India.

I just upgraded to Fedora 9.

When I try to connect through either modem, it seems the connection is made
(Ping) but pppd issues some garbage and Firefox is unable to recognize the
connection. The issue seems similar in both cases. Below is some output. I have
posted in various forums, no solution yet.

Using the ZTE MG880 modem

ATDT#777
CONNECT
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Sun May 25 09:23:04 2008
--> Pid of pppd: 6053
--> Using interface ppp0
--> pppd: �}( ؇(
--> pppd: �}( ؇(
--> pppd: �}( ؇(
--> local IP address 220.226.50.155
--> pppd: �}( ؇(
--> remote IP address 220.224.135.106
--> pppd: �}( ؇(
--> primary DNS address 202.138.103.100
--> pppd: �}( ؇(
--> secondary DNS address 202.138.96.2
--> pppd: �}( ؇(

Using the Huawei EC325 modem

--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: AT+CRM=1
AT+CRM=1
OK
--> Modem initialized.
--> Sending: ATDT#777
--> Waiting for carrier.
ATDT#777
CONNECT 230400
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Sun May 25 11:14:08 2008
--> Pid of pppd: 3230
--> Using interface ppp0
--> pppd: ���[08]���[08]���[08]
--> pppd: ���[08]���[08]���[08]
--> pppd: ���[08]���[08]���[08]
--> local IP address 220.226.70.189
--> pppd: ���[08]���[08]���[08]
--> remote IP address 220.224.135.15
--> pppd: ���[08]���[08]���[08]
--> primary DNS address 202.138.103.100
--> pppd: ���[08]���[08]���[08]
--> secondary DNS address 202.138.96.2
--> pppd: ���[08]���[08]���[08]

"zte.bat" holds

cat /proc/bus/usb/devices
modprobe usbserial vendor=0x19d2 product=0xfffd
dmesg
wvdialconf /etc/wvdial.conf
cp wvdial-zte.conf /usr/bin/wvdial.conf
cp wvdial-zte.conf /etc/wvdial.conf
wvdial zte

"wvdial-zte.conf" holds 

[Dialer zte]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = Analog Modem
Phone = #777
Username = XXXXXXXXXX
Password = XXXXXXXXXX
ISDN = 0
SetVolume = 0
FlowControl = Hardware (CRTSCTS)
Modem = /dev/ttyUSB0
Dial Command = ATDT
Baud = 460800
Stupid Mode = 1
Version-Release number of selected component (if applicable):

Could you please resolve the issue? Thanks!

Bala
Comment 1 Kevin Fenzi 2008-06-04 11:50:34 EDT
This seems to have accidentally been filed against the p0f package, when it's
looking like a ppp problem. ;) 

Reassigning it over to ppp to get looked at. 
Thanks for reporting it!
Comment 2 Jiri Skala 2008-06-24 02:36:45 EDT
Hi,
I'd like to ask you following things:

- does the Firefox work if you put IP address (e. g. 81.95.101.9) instead of
www.something....
- are both modems connected to the computer at the same time (I mentioned
hardware-connected)

Thanks for you answer in advance
Comment 3 Bala Krishnamurthy 2008-06-24 04:48:11 EDT
Hi -

In response :
1. No Firefox does not work withe the IP addresses.
2. Only 1 modem is connected at a time (through USB port).

Thanks so much for looking into this. My productivity becomes 0 when I am on the
move since on my dual-boot laptop I am unable to use the Fedora side and I
really need to migrate fully. The funny thing is that both these modems worked
fine with Fedora Core 6. 

Bala
Comment 4 Jiri Skala 2008-06-26 04:53:28 EDT
Hi,

1. Could you send me output of dmesg and /var/log/messages file.
2. What is release number of problematic pppd?
3. Please, try to install older ppp package. There is pkg from FC7 on this linkg

http://koji.fedoraproject.org/koji/buildinfo?buildID=2551

Use rpm -U --force <pkg name>. Let me know if these packeage works fine. There
are also available a couple of packeages from FC9. But we should start on the
link above.

JS
Comment 5 Bala Krishnamurthy 2008-06-26 05:09:38 EDT
Created attachment 310317 [details]
dmesg output

Here is the output of dmesg
Comment 6 Bala Krishnamurthy 2008-06-26 05:11:04 EDT
Created attachment 310318 [details]
Output of /var/log/messages

Here is the /var/log/messages file
Comment 7 Bala Krishnamurthy 2008-06-26 05:56:16 EDT
NO LUCK! 

I downloaded and did the rpm -U --force <pkg name>
Still same problem - shows garbage on terminal, and Firefox does not recognize
connection.

rpm -qa | grep -i ppp
on my system now shows this
ppp-2.4.4-2.i386


My Fedora 9 original pppd was 2.4.4 - 
/usr/sbin/pppd - size 317736 - date 12/03/08

This one that I downloaded was also 2.4.4 - 
/usr/sbin/pppd - size 312332 - date 1/12/2006

dates are dd/mm/yyyy.

Comment 8 Jiri Skala 2008-06-26 08:32:48 EDT
Hi,
thank you for additional info. I'd like to disturb you with testing once more.
Could you test the rpm of FC-6 (ppp-2.4.4-1)

http://koji.fedoraproject.org/koji/packageinfo?packageID=599

Thank you a lot
Comment 9 Bala Krishnamurthy 2008-06-26 09:25:30 EDT
Sorry to say that too does not work.

I got a warning on installation 
... Header V3 DSA Signature NOKEY KEYID 897da07a 

It created /usr/sbin/pppd size 312956 date 25/7/2005. 
But again when I ran the script the same garbage came up on the screen
Appreciate your help!
Comment 10 Bala Krishnamurthy 2008-06-26 09:26:24 EDT
Sorry to say that too does not work.

I got a warning on installation 
... Header V3 DSA Signature NOKEY KEYID 897da07a 

It created /usr/sbin/pppd size 312956 date 25/7/2006. 
But again when I ran the script the same garbage came up on the screen
Appreciate your help!
Comment 11 Bala Krishnamurthy 2008-09-19 21:55:40 EDT
Hi its September 2008. I tried the modem ZTE-MG880 again.

I continue to get the garbled characters in the shell view on running pppd. But - now firefox is able to connect to the net. I have been using it for a week now - its working fine. I don't recall any unusual changes to my system...
Comment 12 Jiri Skala 2008-10-17 05:59:39 EDT
Hi,
I read BZ #467004 inclusive links that are in this bug (there is a patch). I have no this modem available but it seems to be similar or the same problem.
Comment 13 Jiri Skala 2008-12-11 07:06:09 EST
There is new release in rawhide there is fixed bug #467004. I have the same opinion that it could solve your problem. Please, can you test this package?
Comment 14 Bala Krishnamurthy 2008-12-11 22:55:34 EST
Jiri -

The pppd connection has been working for the past month. I think it is exactly the same or related issue. 

By accident, I noticed that in Network Manager, the DNS settings were not set, and I reset them. The connection through Firefox started working fine then. I thought I would test for a while and then report. Then again after a few weeks, I lost the connection. I went back into Network Manager and saw that the DNS settings were lost again. I reset them, and that did the trick again. No problems. 

I have to mention that the DNS settings were blank, not the settings as listed in bug #467004. As long as it works... 

I am still on Fedora 9 and I think it will be a while before I am in a position to test on Rawhide. But I think we can close this bug issue.

Thanks so much!
Bala
Comment 15 Jiri Skala 2008-12-12 01:56:43 EST

*** This bug has been marked as a duplicate of bug 467004 ***

Note You need to log in before you can comment on or make changes to this bug.