Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 449890 - Glipper gnome panel widget crashes on gnome login
Summary: Glipper gnome panel widget crashes on gnome login
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: glipper
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Damien Durand
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-04 06:43 UTC by Valent Turkovic
Modified: 2009-07-14 16:30 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-07-14 16:30:12 UTC
Type: ---


Attachments (Terms of Use)
First crash report (384.56 KB, text/plain)
2008-06-17 22:57 UTC, Richard Guest
no flags Details
Second crash report (384.68 KB, text/plain)
2008-06-17 22:58 UTC, Richard Guest
no flags Details
error message (18.47 KB, image/png)
2008-10-12 13:25 UTC, Valent Turkovic
no flags Details

Description Valent Turkovic 2008-06-04 06:43:53 UTC
Description of problem:
I have added glipper widget to gnome panel and it works until I reboot and login
for the first time. Then I get an error saying that glipper has made an error
and that I get offered to delete it off the gnome panel.

If I just add it again it works ok. It seams to have some issue with gnome
during login.

Version-Release number of selected component (if applicable):


How reproducible:
50% of the time.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Derek Cramer 2008-06-13 09:22:44 UTC
Fwiw, I'm seeing this as well. Was going to raise a bug until I found this one.

Comment 2 Juan Pablo Giménez 2008-06-14 02:17:39 UTC
Me too...

Comment 3 Valent Turkovic 2008-06-14 06:24:57 UTC
Damien do you need some feedback, logs or something to fix this issue?

Comment 4 Richard Guest 2008-06-17 22:56:00 UTC
Ditto here.
I have a couple of bugreports from bugbuddy to attach...

Comment 5 Richard Guest 2008-06-17 22:57:03 UTC
Created attachment 309677 [details]
First crash report

c/o bugbuddy

Comment 6 Richard Guest 2008-06-17 22:58:35 UTC
Created attachment 309678 [details]
Second crash report

c/o bugbuddy... I could post heaps of these, but I won't.

Comment 7 Valent Turkovic 2008-06-25 23:05:22 UTC
do you need some more feedback for fixing this bug?

Comment 8 Valent Turkovic 2008-10-05 20:14:40 UTC
I'm seeing this still in F9 but also in Fedora 10 beta. Please look at this.

Cheers.

Comment 9 Valent Turkovic 2008-10-10 15:45:00 UTC
is there a way I can capture this crash and provide more feedback for you?

Comment 10 Valent Turkovic 2008-10-10 15:51:21 UTC
I read on the glipper mailing list glipper is not maintained anymore :(

Is it possible to revert to older version of glipper? Older versions worked better and are written in C, new one is written in Python.

Comment 11 Valent Turkovic 2008-10-10 15:59:27 UTC
message about glipper not being maintained anymore:
http://snipurl.com/glipper  [sourceforge_net]

Comment 12 James Westby 2008-10-10 16:47:53 UTC
Hi,

This bug has been reported in Ubuntu too, you can read it at

  https://bugs.launchpad.net/bugs/213494


we've got some way to debugging it, but no real fix yet.

Apparently inserting a delay in to the applet makes it work. My
current guess is a race condition between threads reading from
the history file.

Thanks,

James

Comment 13 Valent Turkovic 2008-10-10 18:02:00 UTC
http://kernelreloaded.blog385.com/index.php/archives/glipper-is-dead-long-live-glipper/

on my blog Jean-François Martin suggested using Parcellite (http://parcellite.sourceforge.net)

Comment 14 Christoph Wickert 2008-10-10 22:16:46 UTC
(In reply to comment #13)
> on my blog Jean-François Martin suggested using Parcellite

Although I agree with Jean-François this is no fix for this big, so no need eo mention it here.

Could somebody please test, if the packages from 
http://koji.fedoraproject.org/koji/taskinfo?taskID=873927
fix the problem? TIA!

Comment 15 Valent Turkovic 2008-10-12 10:34:52 UTC
It looks like it is fixed, thanks Christoph!

Comment 16 Valent Turkovic 2008-10-12 13:25:17 UTC
Hold the presses, it seams that it still doesn't work :(

I tried logging off and logging on, that worked ok, but now that I have rebooted the laptop I still get the error :(

Look at the screenshot.

Comment 17 Valent Turkovic 2008-10-12 13:25:50 UTC
Created attachment 320142 [details]
error message

error message after rebooting and logging in...

Comment 18 Richard Guest 2008-11-13 21:01:22 UTC
Just out of curiosity, any chance you guys are using synergy as well?

I've noticed some strangeness with synergy and clipboard guff recently and was thinking it might be causing glipper to crash somehow...

Comment 19 Valent Turkovic 2008-11-14 15:38:08 UTC
I'm not using synergy.

Comment 20 Richard Guest 2008-11-14 21:49:41 UTC
K. Never mind :-)

Comment 21 Kevin Verma 2008-12-19 10:29:59 UTC
This bug reproduces in F10 still, is there a build of glipper-1.0-5 for fc10 ?

Comment 22 Christoph Wickert 2008-12-19 22:05:55 UTC
No, because the patch I applied in 1.0-5 definitely does not fix the problem. I have to admit that I'm a clueless here, but someone else on #fedora-devel said he wanted to look at it. Sorry I forgot who it was. :(

BTW: What is with the owner of this package? Damien, are you still around?

Comment 23 Kevin Verma 2009-02-12 09:35:57 UTC
Not sure if anyone has comeup with a workaround to at-least make this applet reload when it fails completely on startup of gnome-session. 

I think it will be a good to explore workaround if a fix can't be developed, however even I failed to work a workaround. 

But for now I found an alternative app which looks to be working fine with Gnome so far, thought I'll let others know as well. 

# yum install parcellite

Cheers !

Comment 24 Bug Zapper 2009-06-10 01:23:46 UTC
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 25 Bug Zapper 2009-07-14 16:30:12 UTC
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.