Bug 449909 - User Mode Linux (UML) broken on Fedora 9
User Mode Linux (UML) broken on Fedora 9
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i386 Linux
low Severity high
: ---
: ---
Assigned To: Roland McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 04:46 EDT by Ronald Wahl
Modified: 2008-07-03 23:40 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.6.25.9-76.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-02 02:34:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 450501 None None None Never

  None (edit)
Description Ronald Wahl 2008-06-04 04:46:31 EDT
Description of problem:

User Mode Linux (UML) kernels do not start on Fedora 9 anymore.

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. Download UML kernel from http://user-mode-linux.sourceforge.net/ (no
filesystem required)
2. Uncompress the kernel (bunzip2 ...)
3. Make it executable (chmod 755 ...)
4. Start the UML kernel
  
Actual results:

$ ./linux-2.6.24-rc7 
Core dump limits :
        soft - 0
        hard - NONE
Checking that ptrace can change system call numbers...OK
Checking syscall emulation patch for ptrace...OK
Checking advanced syscall emulation patch for ptrace...check_ptrace : expected
SIGTRAP or (SIGTRAP | 0x80), got status = 256

Expected results:

Kernel should not give the error and start

Additional info:

UML mailing list suggests to report this here as it seems to be a ptrace bug in
Fedora 9. See: http://marc.info/?l=user-mode-linux-user&m=121207568609301&w=2

I have not yet found a way to get UML kernels to work and so I cannot really
make use of Fedora 9 because I develop software that requires UML.
Comment 1 Christian Krause 2008-06-11 09:39:32 EDT
I've tried out to rebuild the kernel 2.6.25 without the utrace patch (in Fedora
8, but I'd expect the some behaviour in F9), and UML works fine. Please see my
comment #1 in the associated bug: 450501 .
Comment 2 Chuck Ebbert 2008-06-12 16:35:11 EDT
Fixed in 2.6.25.6-58
Comment 3 Fedora Update System 2008-06-30 12:33:55 EDT
kernel-2.6.25.9-76.fc9 has been submitted as an update for Fedora 9
Comment 4 Fedora Update System 2008-07-01 01:28:31 EDT
kernel-2.6.25.9-76.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5893
Comment 5 Fedora Update System 2008-07-02 02:34:42 EDT
kernel-2.6.25.9-76.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2008-07-03 23:40:19 EDT
kernel-2.6.25.9-76.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.