Bug 449930 - Upgrade to upstream 0.710.05
Upgrade to upstream 0.710.05
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-SOAP-Lite (Show other bugs)
9
All Linux
high Severity high
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 06:37 EDT by Ludek Smid
Modified: 2008-06-29 18:01 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.710.07-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-29 18:01:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ludek Smid 2008-06-04 06:37:45 EDT
Description of problem:

Current version does not work for XMLRPC calls. Not sure about SOAP.

Version-Release number of selected component (if applicable):
perl-SOAP-Lite-0.68-6.fc9.noarch

How reproducible:
Always

Steps to Reproduce:
use XMLRPC::Lite;
my $rpc = new XMLRPC::Lite( $database_url );
my $call = $rpc->call('bugzilla.runQuery', $querydata);

Actual results:
Can't use string as an ARRAY ref while "strict refs" in use at re_eval <snipped
long dump of XML data> at <top level script name>

Expected results:
Result of the call.

Additional info:

Upgrading to upstream 0.710.05 from CPAN fixed the problem.
Comment 1 Mike McGrath 2008-06-24 16:38:10 EDT
Ugh, this figures.  make test is failing horribly in multiple different ways. 
Looking further.  Contacting upstream... why is nothing simple?
Comment 2 Eugene Teo (Security Response) 2008-06-24 18:24:35 EDT
Thanks Mike. I am experiencing exactly the same make test problem last night..
Comment 3 Mike McGrath 2008-06-24 18:39:44 EDT
Ok, built without make test.  Known issue (actually documented in the readme)  I
opened a ticket with upstream hoping they will fix it soon.

http://koji.fedoraproject.org/koji/buildinfo?buildID=53721

Give it a test if you have a moment and I'll push it.
Comment 4 Eugene Teo (Security Response) 2008-06-24 18:45:26 EDT
Awesome. Thanks Mike. I have upgraded perl-SOAP-Lite. I tried running the perl
script I had problems with, and it worked now.
Comment 5 Fedora Update System 2008-06-28 12:08:38 EDT
perl-SOAP-Lite-0.710.07-1.fc8 has been submitted as an update for Fedora 8
Comment 6 Fedora Update System 2008-06-28 12:09:55 EDT
perl-SOAP-Lite-0.710.07-1.fc9 has been submitted as an update for Fedora 9
Comment 7 Fedora Update System 2008-06-29 18:00:21 EDT
perl-SOAP-Lite-0.710.07-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2008-06-29 18:01:34 EDT
perl-SOAP-Lite-0.710.07-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.