Bug 449956 - perl 5.10 breaks webmin and others
perl 5.10 breaks webmin and others
Status: CLOSED DUPLICATE of bug 448735
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On: 448735
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 09:51 EDT by Matt Castelein
Modified: 2008-06-13 05:19 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-13 05:19:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Castelein 2008-06-04 09:51:38 EDT
Description of problem: Upgrading to latest perl breaks webmin and some other
software.  @INC does not contain the path to the new perl.


Version-Release number of selected component (if applicable):
perl.i386 4:5.10.0-22.fc9

How reproducible:
Always

Steps to Reproduce:
1.Run webmin
2.Select affected modules
3.Module loading fails
  
Actual results:
Can't locate File/Glob.pm in @INC (@INC contains: /usr/libexec/webmin
/usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7
/usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5
/usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7
/usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5
/usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/5.8.8 .)

Expected results:
Modules run as normal

Additional info:
Comment 1 Martin Ellison 2008-06-05 05:06:36 EDT
Lots of things appear to be broken, at least on x64:

 ~> zim
Can't locate File/BaseDir.pm in @INC (@INC contains: /usr/bin/../lib
/usr/local/lib64/perl5/site_perl/5.10.0/x86_64-linux-thread-multi
/usr/local/lib/perl5/site_perl/5.10.0
/usr/lib64/perl5/5.10.0/x86_64-linux-thread-multi /usr/lib/perl5/5.10.0
/usr/local/lib64/perl5/site_perl/5.10.0/x86_64-linux-thread-multi
/usr/local/lib/perl5/site_perl/5.10.0
/usr/lib64/perl5/vendor_perl/5.10.0/x86_64-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl .) at (eval 2) line 2.
BEGIN failed--compilation aborted at (eval 2) line 2.

~> perl -MCPANPLUS
Can't locate CPANPLUS.pm in @INC (@INC contains: /usr/local/l.....
~> perl -MCPAN
Can't locate CPAN.pm in @INC (@INC contains: /usr/local.....
etc
Comment 2 Martin Ellison 2008-06-05 05:10:08 EDT
Much of my @INC does not exist:
~> perl -e "for my \$d (@INC) {print qq{\$d does not exist\\n} unless -d \$d;}"
/usr/local/lib64/perl5/site_perl/5.10.0/x86_64-linux-thread-multi does not exist
/usr/local/lib/perl5/site_perl/5.10.0 does not exist
/usr/local/lib64/perl5/site_perl/5.10.0/x86_64-linux-thread-multi does not exist
/usr/local/lib/perl5/site_perl/5.10.0 does not exist
Comment 3 Marcela Mašláňová 2008-06-10 07:21:42 EDT
We runned into some difficulties with programmes which weren't rebuild with
perl-5.10. Also there are differences between x86 and i386 architectures. We are
still working on it.
Comment 4 Ralf Corsepius 2008-06-10 07:45:59 EDT
(In reply to comment #3)
> We runned into some difficulties with programmes which weren't rebuild with
> perl-5.10. Also there are differences between x86 and i386 architectures.
Marcela, I don't think this issue is related to the @INC problem.

I think, the issue reported here, is a mal installation, because the @INC above
is that of a perl-5.8 installation and doesn't even contain any trace of perl-5.10.
Comment 5 Marcela Mašláňová 2008-06-10 08:30:30 EDT
Webmin
isn't packaged into Fedora. I tried it and didn't find any problems. Could you
be more concrete about affected modules? I can't say if it's really problem of perl.

CPANPLUS
wasn't find because we loose required package (perl-IPC-Run), that will be fixed.

CPAN
is working for me normally: perl -MCPAN -e shell; or use command cpan

zim
I didn't test now, but I check the missing requires.
Comment 6 Martin Ellison 2008-06-10 11:01:42 EDT
My problem was a bad upgrade that left yum pointing to the F8 repository. I have
fixed that and upgraded, and most of my perl problems have gone away. perl -e
"for my \$d (@INC) {print qq{\$d does not exist\\n} unless -d \$d;}" now does
not produce any output. zim now segfaults but runs happily under the debugger (?!)
Comment 7 Matt Castelein 2008-06-10 11:12:59 EDT
(In reply to comment #5)
> Webmin
> isn't packaged into Fedora. I tried it and didn't find any problems. Could you
> be more concrete about affected modules? I can't say if it's really problem of
perl.

bootup and shutdown was the first module I noticed broken, instead of the frame
loading there was just a message about "Can't locate File/Glob.pm in @INC"
Comment 8 Marcela Mašláňová 2008-06-11 03:35:07 EDT
#7
Do you tried find Glob.pm?

locate Glob.pm
/usr/lib/perl5/5.10.0/File/DosGlob.pm
/usr/lib/perl5/5.10.0/i386-linux-thread-multi/File/Glob.pm
/usr/lib64/perl5/5.10.0/x86_64-linux-thread-multi/File/Glob.pm

I tried bootup setting without any problem.
Comment 9 Marcela Mašláňová 2008-06-13 05:19:39 EDT
Problem with paths was solved here: 448735. Please try and in case you have
still problems feel free to reopen it.

*** This bug has been marked as a duplicate of 448735 ***

Note You need to log in before you can comment on or make changes to this bug.