Bug 449980 - NetworkManager applet doesn't auto-detect my wired network connections
NetworkManager applet doesn't auto-detect my wired network connections
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 11:38 EDT by Raul Acevedo
Modified: 2008-06-04 14:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-04 14:24:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raul Acevedo 2008-06-04 11:38:20 EDT
Description of problem:
The NetworkManager applet doesn't automatically detect my wired connections.  I
have two: inbound Internet (eth0), and outbound to my internal network (eth1).

Version-Release number of selected component (if applicable):
0.7.0

How reproducible:
Always

Steps to Reproduce:
1. Login.
2. Left or right click on NM applet.
  
Actual results:
Left click shows my two ethernet cards, grayed out, saying each one is
"Unmanaged".  If I right click and select Edit Connections, it doesn't show
anything under Wired connections.

Expected results:
NM should auto-detect my wired connections, and that they are up and running,
and do something useful with them like show them.

Additional info:
If the reason NM doesn't show anything is because I am not root, that is stupid
and confusing.  It should at least show the connections, because they are there,
but then give me a reasonable and explanatory error if I do something I can't
because I am not root.  As it is, it is really confusing; I *think* my network
connections are up, but why do they not show up???
Comment 1 Dan Williams 2008-06-04 14:24:13 EDT
Yes, they are "unmanaged" because you've decided not to allow NetworkManager to
control those interfaces.  NetworkManager only knows about interfaces that
you've told it to control.  If you'd like NM to control these interfaces, you
can mark them as "Controlled by NetworkManager" in system-config-network.  If
you'd prefer to keep using the static network scripts, you can:

sudo /sbin/chkconfig NetworkManager off

Hope this helps...
Comment 2 Raul Acevedo 2008-06-04 14:27:41 EDT
That does help, thank you!

Note You need to log in before you can comment on or make changes to this bug.