Bug 449982 - Network interfaces don't start up enabled even if ONBOOT=yes
Network interfaces don't start up enabled even if ONBOOT=yes
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: net-tools (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Radek Vokal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 11:47 EDT by Raul Acevedo
Modified: 2008-08-01 13:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-31 13:46:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of lspci (950 bytes, text/plain)
2008-07-11 03:56 EDT, Raul Acevedo
no flags Details
output of ifconfig (1.42 KB, text/plain)
2008-07-24 01:10 EDT, Raul Acevedo
no flags Details
output of nm-tool (1.03 KB, text/plain)
2008-07-24 01:12 EDT, Raul Acevedo
no flags Details

  None (edit)
Description Raul Acevedo 2008-06-04 11:47:05 EDT
Description of problem:
Neither eth0 nor eth1 startup when my computer boots, I have to explicitly
enable them (either with ifup eth0/eth1 or system-config-network), even though I
have "Activate device when computer starts" checked and I can see
/etc/sysconfig/network-scripts/ifcfg-eth0 says ONBOOT=yes.

Version-Release number of selected component (if applicable):
All latest updates on Fedora Core 9.

How reproducible:
Every time.

Steps to Reproduce:
1. Reboot computer.

Actual results:
Network interfaces are disabled.

Expected results:
Network interfaces should be enabled.

Additional info:
Comment 1 Zdenek Prikryl 2008-07-08 08:10:36 EDT
Hello,
could you add the output of "$ lspci" and as an attachment? And if a computer
booting, do you see something like this?:

Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0:                                [  OK  ]
Determining IP information for eth0:                       [  OK  ]

Do you use NetworkManager? If so, is it enabled in "$ system-config-services"?

You can also try "$ service network restart".
Comment 2 Raul Acevedo 2008-07-11 03:56:39 EDT
Created attachment 311555 [details]
Output of lspci
Comment 3 Raul Acevedo 2008-07-11 03:58:34 EDT
Oddly, I don't see the "Bringing up loopback/interface eth0" lines, nor
"Determining IP information for eth0", which I know I've always seen in prior
Fedora releases during boot, but now that you mention it, I'm pretty sure I
don't see them in Fedora 9.

NetworkManager is enabled for runlevels 3-5 (I boot into runlevel 3).

Thanks for the service network restart tip, normally I've run ifdown/ifup
manually but that's a little easier.
Comment 4 Zdenek Prikryl 2008-07-15 05:26:11 EDT
If NetworkManager is enabled, then you will not see messages above. The network
configuration is done by this tool. I suppose that at the boot you see something
like this:

Setting network parameters...                              [  OK  ]
Starting NetworkManager daemon:                            [  OK  ]

Could you add the output of "$ ifconfig" after the boot as an attachment? And do
you have NetworkManager applet enabled? If so, what do you see, if you click on
it by left button?
Comment 5 Zdenek Prikryl 2008-07-15 06:10:31 EDT
Also, add the output of "$ nm-tool" as an attachment. Thanks.
Comment 6 Raul Acevedo 2008-07-24 01:10:50 EDT
Created attachment 312533 [details]
output of ifconfig
Comment 7 Raul Acevedo 2008-07-24 01:12:11 EDT
Created attachment 312534 [details]
output of nm-tool
Comment 8 Raul Acevedo 2008-07-24 01:20:07 EDT
I do see the "Setting network parameters" and "Starting NetworkManager daemon"
messages during startup.

If I left click on the NetworkManager applet, it shows both "System eth0" and
"System eth1" checked with their appropriate 3Com network cards.

The output of ifconfig and nm-tool is essentially the same after I run "service
network restart".  Note that the output of running that command is thus:

# service network restart
Shutting down interface eth0:                              [  OK  ]
Shutting down interface eth1:                              [  OK  ]
Shutting down loopback interface:                          [  OK  ]
Disabling IPv4 packet forwarding:  net.ipv4.ip_forward = 0
                                                           [  OK  ]
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0:                                [  OK  ]
Bringing up interface eth1:  RTNETLINK answers: File exists
Error adding address 192.168.1.1 for eth1.
RTNETLINK answers: Invalid argument
                                                           [  OK  ]

Also note that eth1, the "internal" network interface, seems to work fine at
startup; I can ssh from my laptop to my server just fine.  But from my server,
eth0 is the one that doesn't seem to work on boot, and which works fine after
restarting network.
Comment 9 Zdenek Prikryl 2008-07-29 08:23:09 EDT
Hmm, please append contents of files /etc/sysconfig/network-scripts/ifcfg-eth* too.

Thanks.
Comment 10 Raul Acevedo 2008-07-30 00:27:40 EDT
Contents of ifcfg-eth0:

# 3Com Corporation 3c905B 100BaseTX [Cyclone]                                  
                                                                            
DEVICE=eth0
BOOTPROTO=none
HWADDR=00:50:04:05:4b:7e
ONBOOT=yes
NM_CONTROLLED=yes
NETMASK=255.255.255.0
IPADDR=64.81.61.238
GATEWAY=64.81.61.1
TYPE=Ethernet
USERCTL=no
PEERDNS=yes
IPV6INIT=no
DNS2=216.231.41.2
DNS1=64.81.79.2
Comment 11 Raul Acevedo 2008-07-30 00:28:24 EDT
Contents of ifcfg-eth1:

# 3Com Corporation 3c905C-TX/TX-M [Tornado]                                    
                                                                            
DEVICE=eth1
BOOTPROTO=none
HWADDR=00:b0:d0:de:2f:27
ONBOOT=yes
NM_CONTROLLED=yes
TYPE=Ethernet
NETMASK=255.255.255.0
IPADDR=192.168.1.1
GATEWAY=192.168.1.0
USERCTL=no
PEERDNS=yes
IPV6INIT=no
DNS2=216.231.41.2
DNS1=64.81.79.2
Comment 12 Zdenek Prikryl 2008-07-30 03:24:52 EDT
(In reply to comment #11)
> GATEWAY=192.168.1.0

Why do you use network address as a gateway address? There should be
192.168.1.{1..254}.


Comment 13 Zdenek Prikryl 2008-07-30 04:12:11 EDT
In both configurations change lines NM_CONTROLLED=yes to NM_CONTROLLED=no.

This options arrange that NM don't try to do anything with your NICs. As I
found, on these days NM support only one active interface (but, this is probably
fixed in rawhide).

Comment 14 Raul Acevedo 2008-07-30 17:19:37 EDT
> Why do you use network address as a gateway address? There should be
> 192.168.1.{1..254}.

To be honest I'm not sure how I ended up using 192.168.1.1 as the IP address and
.0 as the gateway.  It's been a while since I looked at the "proper" way to
configure Linux to provide NAT to a private network, which is what eth1 is.

What is the recommended way of doing this?
Comment 15 Zdenek Prikryl 2008-07-31 03:47:30 EDT
Usually as the gateway address xxx.xxx.xxx.1 is used (note, that in the first
configuration file you have this type of address). I don't know your topology of
the network, so I can only guess what is the "proper" way. In my opinion, if the
second NIC is used as a connection with 192.168.1.xxx subnet, then there is no
need to define the gateway in the second configuration file. Right routing is
done by iptables configuration. If you have additional questions about NAT
configuration, please contact me directly. 

Anyway, does comment #13 help you with starting interfaces?
Comment 16 Raul Acevedo 2008-07-31 13:46:03 EDT
(In reply to comment #13)
> In both configurations change lines NM_CONTROLLED=yes to NM_CONTROLLED=no.
> 
> This options arrange that NM don't try to do anything with your NICs. As I
> found, on these days NM support only one active interface (but, this is probably
> fixed in rawhide).

Changing NM_CONTROLLED to no didn't help.  Then I realized maybe the network
service isn't up in the first place, and it wasn't.  After chkconfig to enable
it everything is back to normal.

I can't imagine Fedora had this disabled by default, otherwise lots of other
people would've complained.  Then again I don't know what I did that would've
caused this to be disabled, I did a clean install (not upgrade) of Fedora, and
given that I didn't even know network was a service (I've been using Fedora
since RedHat 5 and always just set the eth0/eth1 settings appropriately without
having to deal with a network service) I doubt I explicitly disabled it.

Anyway it works now.  Given that I don't know if the network service being
disabled was a bug or user error (more likely since others haven't reported
problems), I'll mark this Not A Bug.
Comment 17 Zdenek Prikryl 2008-08-01 05:30:48 EDT
The NM service is enabled and the network service is disabled by default in F9
(probably because most of users has only one active NIC at the same moment). But
in your case, the network service should be enabled and  NM_CONTROLLED should be
set to "no" in configuration files. Then it should work. As I wrote, NM can set
only one NIC as active which is insufficient, but I think that this will be
fixed in F10.

Nevertheless, this isn't the bug in net-tools.
Comment 18 Raul Acevedo 2008-08-01 13:22:37 EDT
Then it's a real bug, and the bug is that NM can only handle one NIC.  That
makes sense because I'm pretty sure eth1 would actually work on startup, but not
eth0.

I'll leave it up to you guys, whether to leave this as Not A Bug, but from my
point of view it should be considered a bug, and marked "resolved" as fixed in
Fedora 10.

Regardless, thanks again for all your help.  I've now been using Fedora/Red Hat
Linux for 13 years.  Yikes!  :)

Note You need to log in before you can comment on or make changes to this bug.