Bug 449991 - prelink daily cron job fails since upgrade to 9
prelink daily cron job fails since upgrade to 9
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: prelink (Show other bugs)
9
i686 Linux
low Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 12:40 EDT by Matt Castelein
Modified: 2008-06-05 12:24 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-05 12:24:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Castelein 2008-06-04 12:40:08 EDT
Description of problem: prelink daily cron job fails since upgrade to 9


Version-Release number of selected component (if applicable):
prelink-0.4.0-3.i386

How reproducible: always


Steps to Reproduce:
1.let cron.daily run
2.
3.
  
Actual results:
/etc/cron.daily/prelink:

telinit: Unable to send message: Connection refused


Expected results:
prelink does it's think

Additional info:
Comment 1 Jakub Jelinek 2008-06-05 12:24:59 EDT
That's not prelink's fault.
If you have upgraded to 9 from older Fedora without rebooting, then that upgrade
swapped SysVinit with upstart for /sbin/init.  The two implementations are
incompatible, and there is no way to restart SysVinit into upstart init, other
than reboot.
The error you are getting is because upstart's /sbin/telinit isn't able to
communicate to the currently running init prelink's request to reexec, if you run
/sbin/telinit u
by hand, you'll get the same error.

Note You need to log in before you can comment on or make changes to this bug.