Bug 450003 - filesystems don't get cleanly unmounted during shutdown
filesystems don't get cleanly unmounted during shutdown
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
9
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 13:39 EDT by Jeroen Beerstra
Modified: 2014-03-16 23:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-29 04:50:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeroen Beerstra 2008-06-04 13:39:22 EDT
Description of problem:

During shut-down the system fails to unmount my filesystems cleanly. Mainly /usr
and /var (but also /home sometimes) fail to unmount with 'device or resource
busy', at the next boot most of the time orphaned inodes are found especially in
/usr (which I find very strange as I didn't do any recent writes to /usr). 

Version-Release number of selected component (if applicable):

initscripts-8.76.2-1.x86_64

How reproducible:


Steps to Reproduce:
1. Boot system
2. Shutdown
3. Press Ctrl-Alt-F7 to watch the shut-down process
  
Actual results:

/usr and /var fail to unmount repeatedly

Expected results:

all filesystems should get cleanly unmounted after all processes are killed

Additional info:

my filesystems are organised in a non vanilla way, maybe that's part of the problem:

sda->sw raid0->LVM->usr, var and home
sdb->sw raid0
Comment 1 Jeroen Beerstra 2008-06-29 04:50:54 EDT
seems to be related to 451081, booting with noapic seems to fix that and this
problem also. 

Note You need to log in before you can comment on or make changes to this bug.