Bug 450018 - Screen scrambles when laptop undocked or redocked
Screen scrambles when laptop undocked or redocked
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-radeonhd (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Hans Ulrich Niedermann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 15:35 EDT by Matt Anderson
Modified: 2008-10-07 05:49 EDT (History)
3 users (show)

See Also:
Fixed In Version: xorg-x11-drv-radeonhd-1.2.1-3.9.20080917git.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-17 12:08:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (35.28 KB, text/plain)
2008-06-04 16:38 EDT, Matt Anderson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 16232 None None None Never

  None (edit)
Description Matt Anderson 2008-06-04 15:35:01 EDT
Description of problem:
When I attach or detach my laptop from its docking station X leaves graphics
mode and has a few colourful noise characters on the top third.  If I switch to
<ctrl><alt>f1 and back to <ctrl><alt>f7 then the display goes back to normal. 
No applications are closed, the X session appears to be fine.  Sometimes it
doesn't go back right away, but it does come back.

Version-Release number of selected component (if applicable):
xorg-x11-drv-radeonhd-1.2.1-1.1.20080429git.fc9.i386

How reproducible:
Every time.

Steps to Reproduce:
1. Boot and login
2. Undock the laptop
3. Experience issue

  
Actual results:
Screen gets odd characters.

Expected results:
Screen stays in graphics mode and X continues along normally.

Additional info:
This didn't happen on Fedora 8, its only been since I upgraded (via Yum) to
Fedora 9.

Here is the bug in action:
http://www.youtube.com/v/84rxcRSYrUY
Comment 1 Hans Ulrich Niedermann 2008-06-04 16:18:52 EDT
The video perfectly illustrates the issue.

I will need to report this upstream, as this does not happen at all with my
Thinkpad T60 with ATI X1400.

What kind of graphics chip and laptop is that? Do you happen to have an
/var/log/Xorg.0.log file left lying around from such an undock/doc event which
you could attach to this bug?
Comment 2 Matt Anderson 2008-06-04 16:38:42 EDT
Created attachment 308396 [details]
Xorg.0.log

The graphics chip is an ATI Technologies Inc M64-S [Mobility Radeon X2300] and
the laptop is an HP 6910p.

I only have this huge Xorg.0.log file, not one with only the bug showing up. 
I've verified that the bug shows up even when the external HP LP2465 monitor is
not powered or even attached to the docking station.  The dock only provides
wired network, and power.
Comment 3 Leif Gruenwoldt 2008-06-05 09:58:31 EDT
This happens to me too. I have an HP Compaq 8510p laptop with docking station. 


$ rpm -q xorg-x11-drv-radeonhd
xorg-x11-drv-radeonhd-1.2.1-1.1.20080429git.fc9.i386


$ lspci | grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc M76 [Radeon Mobility HD
2600 Series]



Undock Xorg.0.log
------------------------------------------------

(EE) Read error: No such device
(WW) Logitech USB-PS/2 Optical Mouse: Release failed (No such device)
(II) Logitech USB-PS/2 Optical Mouse: Close
(II) UnloadModule: "evdev"
(II) Open ACPI successful (/var/run/acpid.socket)
(II) RADEONHD(0): LVDSSetBacklight: trying to set BL_MOD_LEVEL to: 255
(EE) RADEONHD(0): TMDSAVoltageControl: unhandled chipset: 0x9581.
(II) RADEONHD(0): TMDSA_PLL_ADJUST: 0x0000070B
(II) RADEONHD(0): TMDSA_TRANSMITTER_ADJUST: 0x000000AA
(--) SynPS/2 Synaptics TouchPad auto-dev sets device to /dev/input/event2
(**) Option "Device" "/dev/input/event2"
(--) SynPS/2 Synaptics TouchPad touchpad found
(II) <default pointer>: ps2EnableDataReporting: succeeded


Dock Xorg.0.log
------------------------------------------------

(**) Logitech USB-PS/2 Optical Mouse: always reports core events
(**) Logitech USB-PS/2 Optical Mouse: Device: "/dev/input/event3"
(II) Logitech USB-PS/2 Optical Mouse: Found x and y relative axes
(II) Logitech USB-PS/2 Optical Mouse: Found mouse buttons
(II) Logitech USB-PS/2 Optical Mouse: Configuring as mouse
(II) XINPUT: Adding extended input device "Logitech USB-PS/2 Optical Mouse"
(type: MOUSE)
(II) Open ACPI successful (/var/run/acpid.socket)
(II) RADEONHD(0): LVDSSetBacklight: trying to set BL_MOD_LEVEL to: 255
(EE) RADEONHD(0): TMDSAVoltageControl: unhandled chipset: 0x9581.
(II) RADEONHD(0): TMDSA_PLL_ADJUST: 0x0000070B
(II) RADEONHD(0): TMDSA_TRANSMITTER_ADJUST: 0x000000AA
(--) SynPS/2 Synaptics TouchPad auto-dev sets device to /dev/input/event2
(**) Option "Device" "/dev/input/event2"
(--) SynPS/2 Synaptics TouchPad touchpad found
(II) <default pointer>: ps2EnableDataReporting: succeeded
Comment 4 Fedora Update System 2008-09-17 07:57:03 EDT
xorg-x11-drv-radeonhd-1.2.1-3.9.20080917git.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/xorg-x11-drv-radeonhd-1.2.1-3.9.20080917git.fc9
Comment 5 Hans Ulrich Niedermann 2008-09-17 09:19:53 EDT
Upstream thinks xorg-x11-drv-radeonhd-1.2.1-3.9.20080917git.fc9 should fix this issue. Could you please test? Thank you.
Comment 6 Leif Gruenwoldt 2008-09-17 11:28:25 EDT
(In reply to comment #5)
> Upstream thinks xorg-x11-drv-radeonhd-1.2.1-3.9.20080917git.fc9 should fix this
> issue. Could you please test? Thank you.

Thankyou. The issue is fixed for me with this update.
Comment 7 Fedora Update System 2008-10-07 05:49:08 EDT
xorg-x11-drv-radeonhd-1.2.1-3.9.20080917git.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.