Bug 450025 - Upgrading to device-mapper-multipath-0.4.7-17.el5 breaks multipath.
Upgrading to device-mapper-multipath-0.4.7-17.el5 breaks multipath.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
5.2
i686 Linux
low Severity low
: rc
: ---
Assigned To: Ben Marzinski
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 16:05 EDT by Chris Lober
Modified: 2010-01-11 21:42 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-05 12:05:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Lober 2008-06-04 16:05:25 EDT
Description of problem:

The devnode_blacklist {} keyword has been depricated in the /etc/multipath.conf

http://christophe.varoqui.free.fr/

2006-03-13 multipath-tools-0.4.7 shortlog :
  blacklist
    * add per-device product-string blacklist
    * add a device blacklist
    * add a wwid blacklist
    * deprecate the "devnode_blacklist" keyword ub favor of "blacklist"

Version-Release number of selected component (if applicable):
0.4.7-17.el5

How reproducible:
everytime

Steps to Reproduce:
1. Enable the device_blacklist {} keyword in /etc/multipath.conf
2. Install device-mapper-multipath-0.4.7-17.el5
3. service multipathd start   dies after running and multipath commands fail
  
Actual results:
[root@ncldl38072 ~]# grep devnode_blacklist /etc/multipath.conf
devnode_blacklist {
[root@ncldl38072 ~]# rpm -q device-mapper-multipath
device-mapper-multipath-0.4.7-17.el5
[root@ncldl38072 ~]# service multipathd start
Starting multipathd daemon:                                [  OK  ]
[root@ncldl38072 ~]# ps -ef|grep multipath
root     19067 18803  0 16:02 pts/1    00:00:00 grep multipath
[root@ncldl38072 ~]# multipath -ll
error parsing config file
[root@ncldl38072 ~]# 

Expected results:
[root@ncldl38072 ~]# multipath -ll
mpath0 (3600601608c751a005804047e1687dc11) dm-11 DGC,RAID 5
[size=32G][features=1 queue_if_no_path][hwhandler=1 emc]
\_ round-robin 0 [prio=2][active]
 \_ 0:0:0:0 sda 8:0   [active][ready]
 \_ 1:0:1:0 sdd 8:48  [active][ready]
\_ round-robin 0 [prio=0][enabled]
 \_ 0:0:1:0 sdb 8:16  [active][ready]
 \_ 1:0:0:0 sdc 8:32  [active][ready]


Additional info:

Changing devnode_blacklist{} to blacklist {} in /etc/multipath.conf resolves the
issue but I think it would be better to support both keywords during the RHEL5
release.
Comment 1 Chris Lober 2008-06-04 16:11:58 EDT
I did more research and this is not a bug.

It was an error in my install process.

I attempted to close this as NOTABUG but it would not let me.

Note You need to log in before you can comment on or make changes to this bug.