Bug 450033 - VNC fails to perform autorepeat on keys held down.
VNC fails to perform autorepeat on keys held down.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
9
noarch Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
http://forums.fedoraforum.org/showthr...
:
: 450944 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 17:11 EDT by Rick
Modified: 2013-04-30 19:39 EDT (History)
5 users (show)

See Also:
Fixed In Version: 4.1.2-31.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-08 22:52:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vnc .log file (2.37 KB, text/plain)
2008-06-10 13:11 EDT, Eric Frey
no flags Details
vnc log (2.25 KB, application/zip)
2008-06-11 18:25 EDT, Rick
no flags Details

  None (edit)
Description Rick 2008-06-04 17:11:06 EDT
Description of problem:
Key repeats when held down don't seem to work See this thread
http://forums.fedoraforum.org/showthread.php?p=1022178#post1022178


Version-Release number of selected component (if applicable):
Fedora 9

How reproducible:
100%

Steps to Reproduce:
1.Get Vnc server running on F9 (Not Vino).
2.Bring up on any vncviewer client a conneection to that server
3.Open an text area/field Press down and hold any key.
  
Actual results:
Only one character is ever produced.

Expected results:
Automatic key repeat should kick in and produce many characters.

Additional info:
Comment 1 Adam Tkac 2008-06-10 11:20:07 EDT
I'm not able reproduce this problem on my machine. Would it be possible attach
your session log (in ~/.vnc/ directory) and your ~/.vnc/xstartup, please? Also
please specify your architecture to ensure this is not arch specific problem. Thanks
Comment 2 Eric Frey 2008-06-10 13:11:50 EDT
Created attachment 308842 [details]
vnc .log file
Comment 3 Eric Frey 2008-06-10 13:16:05 EDT
I just attched a log file from my system, which is having the same problem.  I'm
running Core 9 on a VMWare 32 bit VM, running on a Vista RC1 64-bit OS.  RealVNC
4.1.2 client being used.

My .vnc/xstartup file is:

$ cat .vnc/xstartup 
#!/bin/sh

# Uncomment the following two lines for normal desktop:
unset SESSION_MANAGER
exec /etc/X11/xinit/xinitrc

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
twm &

Comment 4 Rick 2008-06-11 18:25:18 EDT
Created attachment 309007 [details]
vnc log
Comment 5 Adam Tkac 2008-06-12 06:19:47 EDT
*** Bug 450944 has been marked as a duplicate of this bug. ***
Comment 6 Mark Mielke 2008-06-15 10:53:05 EDT
I get the same behaviour. Whenever I "hold" a key (what should normally trigger
a key repeat), the following lines are added to ~/.vnc/*.log:

[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
...

(apparently one per 'key repeat' that fails?)


It's very impractical. Fedora 8 worked fine. Fedora 9 is giving me problems.
This is on x86_64 in case that matters.
Comment 7 Adam Tkac 2008-06-16 09:40:39 EDT
I didn't reproduce this but in theory problem might be in missing xkeyboard
extension. Would it be possible test if vnc from
http://kojiweb.fedoraproject.org/koji/taskinfo?taskID=663568 fixes the problem
for you, please? Download your architecture from that link. Thanks
Comment 8 Eric Frey 2008-06-16 10:17:05 EDT
I downloaded and installed the updated vnc.  It did not affect the problem at
all on my system.
Comment 9 Eric Frey 2008-06-16 10:25:31 EDT
Looking at my log file, I usee the same "mieqEnequeue: out-of-order valuator
event; dropping." messages as previously reported. I aso see the following
messages at the beginning of the session:

Mon Jun 16 08:13:27 2008
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on port 5901
 vncext:      created VNC server for screen 0
SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/2484,unix/unix:/tmp/.ICE-unix/2484
** Message: another SSH agent is running at: /tmp/ssh-UtMRxF2484/agent.2484
Window manager warning: Failed to read saved session file
/home/efrey/.metacity/sessions/default1.ms: Failed to open file
'/home/efrey/.metacity/sessions/default1.ms': No such file or directory
Window manager warning: Log level 32: could not find XKB extension.
Failure: Module initalization failed

Mon Jun 16 08:13:39 2008
 Connections: accepted: 192.168.1.102::53577
 SConnection: Client needs protocol version 3.8
 SConnection: Client requests security type VncAuth(2)
libnm_glib_nm_state_cb: dbus returned an error.
  (org.freedesktop.DBus.Error.ServiceUnknown) The name
org.freedesktop.NetworkManager was not provided by any .service files

** (nautilus:2572): WARNING **: Unable to add monitor: Not supported

** (nm-applet:2596): WARNING **: <WARN>  applet_dbus_manager_start_service():
Could not acquire the NetworkManagerUserSettings service.
  Message: 'Connection ":1.30" is not allowed to own the service
"org.freedesktop.NetworkManagerUserSettings" due to security policies in the
configuration file'

I am running with SELinux in non-enforcement mode.


Comment 10 Adam Tkac 2008-06-16 10:39:51 EDT
(In reply to comment #9)
> Window manager warning: Log level 32: could not find XKB extension.
> Failure: Module initalization failed

Hm, this message shouldn't exist. Are you sure that you are using version from
link above? When you run xdpyinfo -display <vnc-displaynumber> |grep XKEYBOARD
do you see XKEYBOARD word?
Comment 11 Mark Mielke 2008-06-16 10:48:39 EDT
I was just about to install your VNC update from my work machine, typed
something wrong, and held the backspace key down and it worked. I do not believe
anything has changed between yesterday and today - no yum updates, and it is the
same VNC session. This suggests to me that the VNC *client* may influence the
bug into occurring. At work, it seems to work from vnc on RHEL 4.x
(4.0-8.1.i386). At home, I connect from Windows XP, which is at least RealVNC
4.1.x if not more recent. Anybody else notice that it only happens from Windows
-> Linux?

I will try with your update this evening.
Comment 12 Eric Frey 2008-06-16 11:49:26 EDT
Relative to the most recent comment (Mark Mielke) - I only run from Windows ->
Linux.  I just downloaded RealVNC 4.4.1, and still have the problem with that.

It appears that I didn't actually apply the first update, pehaps because
vncserver was running when I tried to apply it (?).  I reinstalled it, and it
now works properly (i.e. repeat key IS working normally).  It is working
normally with both VNC 4.1.2 and 4.4.1.
Comment 13 Mark Mielke 2008-06-16 18:41:21 EDT
Success. From the home machine on Windows XP with RealVNC 4.1.2 connecting to
Fedora 9 vnc-server 4.1.2-30.fc9 key repeat failed. Upgraded to 4.1.2-30.1.fc9
as suggested and it now works.

Not sure if it's Windows or the particular version of the RealVNC client that
caused the problem, but I'll confirm again that with 4.1.2-30.fc9 where it
failed from Windows XP VNC client connecting to the server, for the exact same
VNC server session running, it succeeded from a Linux RHEL 4.x VNC client.

Thanks for the patch. One doesn't realize how much one relies on key repeat
until it's gone. :-)
Comment 14 rico sec 2008-06-19 01:08:15 EDT
Also can confirm 4.1.2-30.1.fc9 worked for me. Thank Gods
Comment 15 Will Strang 2008-06-26 20:00:53 EDT
I would like to get this fix.  Where can I find the vnc-server 4.1.2-30.1.fc9
rpm for i386?  The Buildroots for the buildArch tasks under taskID=663568 have
State expired (at least for i386 and x86_64), and show no Built RPMs.  And I
don't see a patch that sounds like it includes this fix in the fedora cvs for
the vnc package.  I'm presumably missing something here, but I can't tell what.
 Thanks.
Comment 16 Alan Ellis 2008-06-29 09:42:33 EDT
I also would like to apply this fix to cure the autorepeat problem.  I'm
currently running vnc-server (4.1.2-30.fc9) for i386.  The link in Comment #7 no
longer contains the fixed version rpm.
Thanks.
Comment 17 Fedora Update System 2008-07-04 07:23:46 EDT
vnc-4.1.2-31.fc9 has been submitted as an update for Fedora 9
Comment 18 Fedora Update System 2008-07-06 02:12:32 EDT
vnc-4.1.2-31.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update vnc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6120
Comment 19 Fedora Update System 2008-07-08 22:52:46 EDT
vnc-4.1.2-31.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.