Bug 450040 - Freedoom 0.6.2 is out
Freedoom 0.6.2 is out
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: freedoom (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Wart
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 17:49 EDT by Xavier Bachelot
Modified: 2008-12-22 17:42 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-22 17:42:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xavier Bachelot 2008-06-04 17:49:57 EDT
freedoom 0.6.2 was released on March, 18th 2008, please update. Filing this bug
against Rawhide, but F8 and F9 obviously need to be updated too.
Comment 1 Xavier Bachelot 2008-06-04 18:05:06 EDT
As a side note, I think this package doesn't need to use a disttag, this is pure
datas. Using a dist tag is actually counterproductive, as it forces the
duplication of otherwise identical datas to all the releases. Not sure what
needs to be done to get the rpms copied from one release to another though.
Comment 2 Xavier Bachelot 2008-06-04 18:20:57 EDT
It seems you would need to build the(In reply to comment #1)
> As a side note, I think this package doesn't need to use a disttag, this is pure
> datas. Using a dist tag is actually counterproductive, as it forces the
> duplication of otherwise identical datas to all the releases. Not sure what
> needs to be done to get the rpms copied from one release to another though.

It seems you would need to build the package for the oldest supported fedora
release, then mail rel-eng so they do the needed magic to have the package
inherited for all newer releases permanently.
Comment 3 Wart 2008-06-04 18:24:48 EDT
(In reply to comment #2)
> It seems you would need to build the package for the oldest supported fedora
> release, then mail rel-eng so they do the needed magic to have the package
> inherited for all newer releases permanently.

This is what I've done for other large data packages.  But I wonder if it's
worth it for freedoom since the package is (only?) 7MB.  I usually don't bother
with disttagless data packages except for packages > 20MB or more.  I know
that's a pretty arbitrary cutoff, but in this case the savings would be rather
small (7MB per release).
Comment 4 Xavier Bachelot 2008-06-04 18:40:41 EDT
Actually, I took this opportunity to learn how the rpm duplication across
releases process works. I thought about the size (non-)issue in this case, but
was lazy and didn't bother to look. Anyway, as you said, the size limit is
arbitrary, and what may be only a little saving for someone might still worth it
for another. No strong feeling either way, this was just meant as a note, in
case you didn't know about the potential issue and workaround.

Regards,
Xavier
Comment 5 Wart 2008-06-04 19:09:47 EDT
I've built this for rawhide, but I'd like to wait to push it to F-9 and F-8
until this is fixed:
http://sourceforge.net/tracker/index.php?func=detail&aid=1939857&group_id=61157&atid=498937

We will need to test this with both prboom and vavoom, as both of these doom
engines are in Fedora and depend on prboom.
Comment 6 Bug Zapper 2008-11-25 21:22:58 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Wart 2008-12-22 17:42:00 EST
The version of 'rawhide' when this bug was filed is now 'F10'.  Thus, the latest version of freedoom is now available in F-10.

Note You need to log in before you can comment on or make changes to this bug.