This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 450047 - Can't install new packages. packagekit complains I am offline
Can't install new packages. packagekit complains I am offline
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
9
All Linux
high Severity high
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 18:38 EDT by Bill C. Riemers
Modified: 2008-06-05 08:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-05 08:50:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill C. Riemers 2008-06-04 18:38:27 EDT
Description of problem:

I am trying to Add/Remove programs.  I selected a package to install, but
whenever I click install I get the following error message:

"No network connection available:  Cannot install when offline"

But of course I am not offline, in fact I'm connected to redhat entering this
bug report.


Version-Release number of selected component (if applicable):


How reproducible:

100%

Steps to Reproduce:
1. Try installing a package.
2.
3.
  
Actual results:

Error message.

Expected results:

Package installs.


Additional info:
Comment 1 Richard Hughes 2008-06-05 04:01:39 EDT
Are you using NetworkManager?
Comment 2 Bill C. Riemers 2008-06-05 07:29:20 EDT
Yes & No.

NetworkManager was running, but it wasn't working.  My network was started
manually with the command: "service network start".

I just tried "service NetworkManager stop", and now packagekit no-longer
complains it is offline.

BTW.  Is it possible to invoke the old "pirut" program on Fedora 9?  I really
dislike this new interface, as there seems to be no way to select all
categories, and no way to select multiple packages to install in a single
transaction.   (Meaning I can't just check off the things I want installed and
uninstalled, and go back to work while it downloads.)


Comment 3 Richard Hughes 2008-06-05 08:50:38 EDT
Ahh, PK got confused as NM was up and was reporting there was no network. Please
see http://fedoraproject.org/wiki/PackageKitFaq for NM and future enhancements
to PackageKit. We already have multiple package installs and removes in the API
in rawhide.

Note You need to log in before you can comment on or make changes to this bug.