Bug 450053 - Software Update Applet has stopped the hibernate from taking place
Software Update Applet has stopped the hibernate from taking place
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 19:06 EDT by xunilarodef
Modified: 2009-01-14 08:51 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-14 08:51:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xunilarodef 2008-06-04 19:06:43 EDT
Description of problem:
When attempt to hibernate system, rewarded with popup from bottom panel:
   Request to hibernate
   [! icon] Software Update Applet has stopped the
   hibernate from taking place.  A transaction that
   cannot be interrupted is running.
Except no update transaction is currently running, and the most recent
update concluded successfully with no visible errors.

One can use System, Administration, Update System to check for updates,
and that returns normally with 
  There are no updates available!

Version-Release number of selected component (if applicable):
  gnome-packagekit-0.1.12-12.20080430.fc9.i386

How reproducible:
  Solidly.  Has failed every time in multiple attempts.  (Although this
system had successfully hibernate multiple times over the past few
weeks until today.)

Steps to Reproduce:
1. System, Shutdown ..., Hibernate
2. [plus some unknown additional conditions or state ... help me find them]

Actual results:
Computer does not hibernate.

Expected results:
I reduce my carbon footprint as the computer hibernates.

Additional info:
  The 2nd line below from /var/log/messages is unusual:

Jun  4 06:25:40 localhost kernel: Restarting tasks ... done.
Jun  4 06:25:40 localhost restorecond: Read error (Interrupted system call)
Jun  4 06:26:07 localhost gnome-power-manager: (ns) Resuming computer

[u@localhost ~]$ uname -r
2.6.25.3-18.fc9.i686
[u@localhost ~]$
Comment 1 Richard Hughes 2008-06-05 04:03:43 EDT
When you get the notification from gnome-power-mananger, can you attach the
output of pkmon please. Thanks.
Comment 2 xunilarodef 2008-06-05 08:05:44 EDT
(In reply to comment #1)
> When you get the notification from gnome-power-mananger, can you attach the
> output of pkmon please. Thanks.

Something is causing pkmon to hang, or at least it does not complete
within a few minutes of starting:

[u@localhost ~]$ pkmon
Tasks:
[none]...
^C
[u@localhost ~]$ pkmon -v
TI:07:50:00	TH:0x8409458	FI:pk-debug.c	FN:pk_debug_init,248
 - Verbose debugging 1 (on console 1)
TI:07:50:00	TH:0x8409458	FI:pk-connection.c
FN:pk_connection_connection_changed_cb,129
 - emit connection-changed: 1
TI:07:50:00	TH:0x8409458	FI:pk-monitor.c	FN:main,218
 - connected=1
TI:07:50:00	TH:0x8409458	FI:pk-client.c	FN:pk_client_connect,3374
 - connect
TI:07:50:00	TH:0x8409458	FI:pk-job-list.c	FN:pk_job_list_connect,195
 - connect
TI:07:50:00	TH:0x8409458	FI:pk-monitor.c	FN:main,249
 - refreshing task list
Tasks:
[none]...
TI:07:51:21	TH:0x8409458	FI:pk-connection.c
FN:pk_connection_connection_changed_cb,129
 - emit connection-changed: 0
TI:07:51:21	TH:0x8409458	FI:pk-monitor.c	FN:pk_connection_changed_cb,165
 - connected=0
TI:07:51:21	TH:0x8409458	FI:pk-client.c	FN:pk_connection_changed_cb,3383
 - connected=0
TI:07:51:21	TH:0x8409458	FI:pk-job-list.c	FN:pk_connection_changed_cb,204
 - connected=0

Running this query as root reveals no more information.

Comment 3 xunilarodef 2008-06-05 08:16:20 EDT
As /var/log/yum.log shows, this version of packagekit arrived via
update a few days ago.  After that update, this system successfully
hibernated and resumed at least three times before failures began on
Jun 04.  The failure to hibernate first happened after the update of:
  bind-libs-...
  libpng-...
  bind-utils-...

Jun 02 07:05:44 Updated: PackageKit-libs-0.1.12-13.20080522.fc9.i386
Jun 02 07:06:01 Updated: samba-common-3.2.0-1.rc1.14.fc9.i386
Jun 02 07:06:04 Updated: libsmbclient-3.2.0-1.rc1.14.fc9.i386
Jun 02 07:06:05 Updated: yum-packagekit-0.1.12-13.20080522.fc9.i386
Jun 02 07:06:11 Updated: PackageKit-0.1.12-13.20080522.fc9.i386
Jun 04 06:32:20 Updated: 32:bind-libs-9.5.0-32.rc1.fc9.i386
Jun 04 06:32:30 Updated: 2:libpng-1.2.29-1.fc9.i386
Jun 04 06:32:41 Updated: 32:bind-utils-9.5.0-32.rc1.fc9.i386

Curiousity:  This is not the first time, but it is still unusual for
a package name as shown in this file to begin with numbers followed
by a colon, as these three do.  What is the significance of that?
Comment 4 xunilarodef 2008-06-05 08:40:31 EDT
  When Fedora 9 was first installed on this system, I would see
a popup from bottom panel:
  Sleep warning
    Your laptop will not sleep if you shut the lid as a
    running program has prevented this.
    Some laptops can overheat if they do not sleep 
    when the lid is closed.
each time Update System or Add/Remove Software was being run.  At that
time Hibernate / Resume failed with kernel errors, etc.  Once updates
provided a functioning Hibernate / Resume, I do not remember ever
seeing this "Sleep warning" popup message.  But I believe I did see
that message again once on Jun 04 (but not upon successive times that
Update System has been run since).

I have never seen a matching bookend message, similar to:
  Sleep peacefully
    The running program that would have prevented your
    laptop from sleeping has finished, and your 
    system configuration has been restored to normal.
Is there such a message?  Or is the transition that the "Sleep warning"
warns of intended to be a one-way transition?  (I will find out if 
rebooting clears this state once you tell me there is no more information 
you wish to gather while it is in this broken state ... or something else 
forces a reboot.)
Comment 5 Richard Hughes 2008-06-05 08:52:39 EDT
>Is there such a message

There is no such message. Can you reboot and see if that fixes things? Thanks.
Comment 6 xunilarodef 2008-06-05 22:25:24 EDT
(In reply to comment #5)
> >Is there such a message
> 
> There is no such message. Can you reboot and see if that fixes things? Thanks.

Well, after a restart, I have successfully hibernated and resumed this
system.

Q1: So the:
  Sleep warning
    Your laptop will not sleep if you shut the lid as a
    running program has prevented this.
    Some laptops can overheat if they do not sleep 
    when the lid is closed.
message should be displayed for:
A1A: every transaction, or
A1B: only some transactions which could leave a broken system if interrupted
     and replayed later?

Q2: Is this warning intended to apply
A2A: temporarily only for the duration of the transaction, or 
A2B: during and lingeringly after the transaction (as the experience 
     reported here)?

From the wording of the warning message, etc. I would be willing to 
assume A1A and A2A.  Thanks in advance for clarifying.
Comment 7 Richard Hughes 2009-01-14 08:51:13 EST
Okay, cool. Thanks, I hope things are better now.

Note You need to log in before you can comment on or make changes to this bug.